Empire update to 1.15 - The Aquatic Buzzy Village update!

Discussion in 'Empire Updates' started by chickeneer, Mar 15, 2020.

  1. That's unfortunate! But I used the \vaults method this morning, and it's pretty good as well. :) Thanks for investigating!
    _Susu_, luckycordel and Egeau like this.
  2. YAYAYAY!!!!
    _Susu_ and luckycordel like this.
  3. Awesome job Dev team and Chickeneer specifically. I've heard that the jump from 1.12 to 1.13 is like a giant leap with the changes to some of the basic aspects of MC and I was hearing that from CurseForge mod Devs. Re-engineering EMC to move from 1.12.2 to 1.15.2 is a feat in itself plus adding in all the new features and keeping the existing features in place is Outstanding. Great job to all y'all including everyone that worked diligently to test all these changes and additions that make EMC the best MC on the net. :+1: :+1: :+1: :+1: :+1: Five thumbs up.
    _Susu_, __Devil_, luckycordel and 2 others like this.
  4. Question. I haven't played in a year or so but logged in with the new update. My guardian farm is broken, no guardians spawning. They were spawning the few times I logged in this past year to get mails/promos, so I assume it was broken because of the patch. Is this common? Did the patch cause already spawned in ocean monuments (and witch huts, etc) to no longer be considered what they are?
    _Susu_, luckycordel and xGGirlx like this.
  5. For your farm to work all it would need is a design change. Due to how things spawn in the ocean now.
    _Susu_ and 607 like this.
  6. Can Pillager Towers be enabled at least. They are locations different from that of a Patrol/Raid entering a village, and there is natural villages in the Frontier, just further out. I have found dozens actually.

    It is sort of punishing those who either live out in the Frontier or those who make the journey out this far only to have this feature taken from them.
    _Susu_ and luckycordel like this.
  7. I am not sure what a Pillager Tower is. But we do have a bug with pillagers not spawning anywhere on the server. You could be seeing this. Next update will fix that issue...
    _Susu_, __Devil_, luckycordel and 3 others like this.
  8. _Susu_, luckycordel and 607 like this.
  9. _Susu_ and luckycordel like this.
  10. Got the same issue with my guardian farm. No mobs are spawning. I use Gnembon's 1.12 farm design. It will take me time to fix it. :/
    _Susu_ likes this.
  11. The update that just went out fixed several things.
    • Added coral->dead coral blocks as natural conversions for persistent items. See note in first post about dirt items.
    • Fixed entity spawning in town. (No iron golems).
    • Enabled pillagers. We accidentally were overzealous in limiting them. They should start appearing in your explorations. Note that patrols/raids are only enabled for the wastelands.
    • Improved cross-server chat tag.
    • Fixed an issue with shop signs not preferring their attached block.
    • Fixed a bug where you couldn't leave the end when you had a bed spawn there.
    • Added a permission check for berry bush harvesting.
    • Fixed issues with old spawn eggs not stacking properly, and their shop signs not working.
    • Improved an issues with bees trying to load chunks, causing lag.
  12. This is exactly what EMC needed! I will be playing soon! Thank you EMC Devs <3
  13. Suggestion for /vault n and /vault p to be replacements for the arrow keys (/vault previous/next)

    this way you can spam scrollin throughout vaults
    _Susu_, luckycordel and 607 like this.
  14. Have you tried the changes I made to /vaults? I will still consider your suggestion, but just want you to know what I have already tried.
  15. Yes, that is usefull for organized people... haha

    Vaults tend to get messy over time so the vaults arrow keys were great. Adding those commands transforms:

    /vault 1 ESC /vault 2 ESC...
    /vaults move mouse ESC /vaults move mouse...


    /vault 1
    /vault n
    /vault n

    ^easily repeatable movement. Others you have to type and stuff
  16. I have one vault page that already had more than 10 in it. I haven't open my vault yet past page 1. Any chance they could be affected (like disappear or something weird like that)? They are all staff/ex-staff sigs or mostly 1-2 page mesasges.

    So this didn't work for me:

    The contents of the shulker:
    (The paper stack is unused ocean monument maps. Is that the issue? Other then that I don't know why it won't work. There are no books.)
    _Susu_, Raaynn and 607 like this.
  17. I tried it with a shulker box full of regular sand, that worked fine.
    _Susu_ and 607 like this.
  18. Maps have been giving trouble with vault. I'll see what I can do
    _Susu_, khixan and ThaKloned like this.
  19. Next time I can get on I will try without the maps inside. Thanks :)
    _Susu_ and khixan like this.
  20. I would be careful as written books may be a little glitchy. Was moving some yesterday in just a chest and they were acting odd.. kind of like heads used to... duplicating and disappearing for a sec. Had 1 disappear altogether on me.
    In general I found it better if I moved them slowly.
    _Susu_, 607 and ThaKloned like this.