MC 1.8 and Mods

Discussion in 'General Minecraft Discussion' started by BreezyMan, May 1, 2015.

  1. I've seen some issues where people are having trouble getting Forge, LiteLoader and mods to work. Playing with it for a couple of hours to figure out what does and doesn't work out of the stuff I currently have loaded in my 1.7.10 and the new versions need to make things work... Here is a list of what I've found:

    Downloaded the new 1.8.4 minecraft client and the following I got to install and work successfully with...


    mod_worldeditcui_1.8.0_02_lite_mc1.8.litemod (This looks neat... I wanted to try it)

    The following blew up the MC client or it wouldn't start:
    InventoryTweaks-1.59-dev-152.jar (I got use to using this one.)

    This one didn't blow anything up but also didn't work. Didn't see a 1.8 update for it either.

    Just wanted to share this with anyone having trouble getting MC working with forge and LiteLoader.

    Please post and let everyone know of and mods you have working / not working and if you know of an updated version of them.

    I was bouncing around so much between cleaning out my versions and re-installing thing to grab the links to the above file. Easy to find though with Google.

    Hope this helps.
    cadgamer101 and ShelLuser like this.
  2. OK, the forge installer only works on 1.8, not on 1.8.x so the current working versions are for 1.8 only, nothing later.

    I have managed to get 1.8 working with the following (changes from Breezy's install in yellow)
    use the recommended installer at





    ShelLuser, Gawadrolt and BreezyMan like this.
  3. Just an update, seems to be working fine now that we are in 1.8. Voxelmap looks as though it is working with multi-server but may not be...

    Also is much less laggy than before the update.
    ShelLuser, Gawadrolt and BreezyMan like this.
  4. Yes I may have to so a reinstall of this version
    BreezyMan likes this.
  5. Ok, I downloaded the forge installer and it wouldn't open. Changed from 1.8.4 to 1.8 logged into emc, closed minecraft. Tried again, nothing. Reinstalled minecraft completely and deleted all associated file from .minecraft after uninstall completed. (uh oh screenshots) After I got minecraft reinstalled I logged in using 1.8 logged into emc, closed minecraft. Downloaded the recommended forge installer, nothing. Downloaded the latest forge installer, nothing. When I say nothing I mean I go to run the installer exe and literally nothing happens. I think I remember having the same problem the first time I downloaded forge for 1.7.10 but I don't remember what I did to fix it. Anyone have any ideas? This is driving me crazy I really need a minimap and to have a "better sprinting" type mod or my hair is gonna fall out XD
  6. I used light loader the last time and voxel minimap for 1.8 I am still using this and it's working
    BreezyMan and Gawadrolt like this.
  7. Hey Gawadrolt. I assume you are on windows. Right-click the forge installer and choose Run as administrator. See hwo that goes. If not, knowing what windows version you have would help.
    Gawadrolt likes this.
  8. Forgot to mention that I tried that. I'm about to uninstall Java, which I'm pretty sure is what I had to do last time.
  9. Gawadrolt likes this.
  10. Thanks skydragon. Unfortunately google is not your friend when looking for 1.8 mods as the advertisers have been all over putting "1.8" on mods that still haven't been updated from 1.7.10 :-(
  11. I got the installer to work. Here is how, note that this is on windows 7:

    Uninstall all versions of Java from PC via the run box (Windows key + r) and type in "appwiz.cpl" (without the quotations)

    Once uninstalled, go to the run box again, and type in "regedit" (without the quotations) Once in Regedit, first go to HKEY_CURRENT_USER>Software, and delete the entire javasoft folder. Then, while still in Regedit, go to HKEY_LOCAL_MACHINE>Software, and then delete the javasoft folder there. Close regedit.

    Then open the run box again, and type in "%appdata%" (without the quotations) This will take you to a Roaming profile under the appdata folder. Look for any folders named "Sun", if you see one, delete it. Once you've checked the roaming folder, click the appdata link in the Explorer window address bar, and then that should take you to three options: roaming (where you just were), local, and locallow. Look in the other two folders for a Sun folder, if you see one delete it. Once you've done that, go back to the Java website and install the latest Java. Once it's finished, try running the .jar file again, and it SHOULD launch the installer finally. As I stated, that worked for me, hopefully it will work for you.

    Note: if it is not your computer do not modify the registry. The registry contains very important information for your computer to run correctly.
  12. Yeah its a double post, triple if you include yesterday but if I do edit 25 minutes later this probably isn't going to get seen and its completely unrelated:

    Which liteloader build are you all using?41 or 42? I am going to try 42 since its 2 months old I hope not to have any problems with it.
  13. I downloaded and installed Optifine 1.8.4 from and it installed and worked just fine.

    I need to find REI Minimap for 1.8.4 though too.
    BreezyMan likes this.
  14. Rei minimap does not have a version for 1.8 at all I don't think. I am trying voxelmap for the first time. Wish me luck.

    Found zyins hud, checked disallowed mods... awwww. will have to try it out on singleplayer if I ever feel like actually using singleplayer again lol.

    The reason they weren't able to get optifine to work is because they are using forge and 1.8, not 1.8.4.... at least I think that is why. I didn't even try to install optifine... perhaps I will see if I can.
  15. REI's Minimap is discontinued afaik. Voxelmap aka Zan's Minimap is the replacement but requires liteloader and that only goes to 1.8, not 1.8.4. So we are stuck with 1.8 until liteloader and forge get updated to 1.8.4. Voxelmap and the rest of the mods I am able to use are listed in my post above.

    As for Skydragons 1.8 list, some may be incompatible or not allowed. I prefer to work from the allowed list only as it means I have no chance of screwing up and getting banned.

    Could anyone responding to this thread please only add mods they have tested and know are approved or not likely to cause moderation issues.

    Your java seems to have been messed up pretty bad Gawadrolt. Make sure you are checking for nasties with your AV and use some free ones like Malwarebytes, Superantispyware and adwcleaner (fom . I clean PC's on a daily basis and those tools save me hours of work.

    Make sure if you are using liteloader that you put mods in the correct version folder, so .minecraft\mods\1.8 for example.
    BreezyMan and Gawadrolt like this.
  16. OK!!! Now that forge is installed and Baradar67 helped me figure out how to use liteloader I have all of my mods installed and ready to go, working great together.

    Forge 1.8 v42
    Liteloader 1.8
    Better Sprinting
    Custom interactions sounds(hoping I can use this to kill nether portal sounds)
    Memory Cleaner(don't know if this really does anything)
    Optifine 1.8 HD_U_D3

    Edit: tabbing does not create a paragraph, it goes to the post button and then spacebar enters the post button.
    BreezyMan, ShelLuser and Baradar67 like this.

    light level overlay(which I think the one I just downloaded makes obsolete)
    NOT ENOUGH ITEMS- I see this on ever youtube video I have ever seen so I'm guessing its a good one

    Also on the damage indicators there is this really annoying thing it does with the light, baradara found that you can make it stop by going into the settings and changing the render thingy to minimal and it won't light stuff up when you are facing a mob/player. Thanks again baradara.
    BreezyMan likes this.
  18. A late comment, I know, but I've only recently started experimenting with mods, and wrote a small guide (when I get into things I like I tend to do that). And I have to say I quite like the experience!

    I found a later version (1.5.13) right here (click 'files', then Voxelmap for 1.8). I can definitely recommend grabbing it because it provides a cool full map. So you press M and you get a full map of the area you're in, including display of optional waypoints. Even better: right click on an area and you can set waypoints. Or right click on a waypoint and you can quickly teleport to it (provided you're an op in the game of course).

    I assume you're using the same Forge version as I am so this version of Optifine won't work. Also see that guide link above. I opted to get the Optifine version for 1.8.0 ("OptiFine 1.8.0 HD U D3") and that works just fine.

    And thanks for your list, guess I got some more mods to look into :)

    EDIT: I should read the whole thread before commenting :rolleyes:
    BreezyMan and Gawadrolt like this.
  19. :p
    Yea. We created this thread right after the servers were moved to 1.8 with the purpose of a way to communicate what we found was working and what was not to help each other get our loaders and mods configuration back up and running. Thank you for the voxelmap update.

    I hope people continue to post updates to the loaders and the mods as they find them or find updates to them.
    ShelLuser likes this.