Why can't I see skins or heads?

Discussion in 'Empire Help & Support' started by _Bunni__, Jun 28, 2016.

  1. I can't see heads or skins. I don't know why! I've tried removing out of date texture packs, relogging, restarting my PC, changing updates (1.9 to 1.10 to 1.9.4, etc). This has been going on for about a week so I think it's more than just a bug. Any suggestions?

    Everything looks like this:

    Any suggestion helps!

    Bunni <3

    testman12345 likes this.
  2. Hmm im not sure this has happened to me before but i just logged back in and it was better.
    testman12345 likes this.

  3. Skins and heads (part of the skin basically) are all retrieved from the Mojang server, so there are a few possibilities here. First start with the most obvious: check your Java version and make sure it's up to date (1.8.0_92 at the time of writing). I doubt it'll help, but it's always something to keep an eye out for.

    There are some general possibilities, including those which only apply to your own skin but I'll mention them here anyway.
    • You recently got a new skin, but used a wrong file (wrong size for example).
    • You messed with your Minecraft game folder and somehow removed important directories.
      • There's one in particular I'm wondering about: assets\skins.
    • You're not using a legal Minecraft account.
      • Note: I'm not saying that you do, only mentioning it as a possible cause.
    • For some reason (network problems?) your computer cannot access the Mojang server.
    Hope these can give you some ideas.
    testman12345 and nuclearbobomb like this.
  4. One more thing. I've noticed that a few of the heads (one or two?) Did actually have skins. The rest did not. Some of the heads' owners may not have had skins. Just a thought.
    testman12345 likes this.
  5. Thank you for your post, it's been quite helpful. However, I have a couple questions.
    • My Java is 1.8.0_25. How do I change this to 1.8.0_95?
    • What do you mean by a not legal Minecraft account?
    I tried deleting and reinstalling Minecraft but I still have these problems. =/
    Thank you!
    Bunni <3
    testman12345 likes this.
  6. One you didn't buy/pirated account
    testman12345 and ShelLuser like this.
  7. You can download the latest Java here: http://java.com/download/. Just click the big red button and you should be well on your way. Careful: sometimes the installer asks you if you want to install other software as well, such as Google Chrome or such: pay close attention to that if you're not interested in all that.

    Nuclear already answered the Minecraft account question. Basically any Mojang account which you didn't got from the Mojang website itself could be a possible issue.
    testman12345 likes this.
  8. :) thanks emc for your continuous giggles
  9. I updated my Java, then deleted and restarted Minecraft but I still can't see skins! My account isn't pirated- I bought it straight from Mojang. Any other ideas?

    Bunni <3

    Theomglover_, ShelLuser and 607 like this.
  10. Are you using Windows or Mac? I'll assume Windows, if not then back to the drawing board for me ;)

    Edit: Be sure to also read Tom's post below mine, he has a very good addition to my story here!

    First of all, just to make sure: this problem happens everywhere, right? Even on the Empire? Because if this only happens in, say, singleplayer or when you're playing with your friends then it might have a different cause.

    I have a suggestion, but it's a drastic one. Find your Minecraft program folder, it's probably somewhere in c:\users\<your name>\AppData\Roaming, and it's called .minecraft. Rename that into something else, for example minecraft_bck. Then try starting Minecraft, it'll require you to log on again. Just do so, start it. Double check your profile and be sure to start 1.9.4, not a later 1.10 version (this is to rule out any oddities). Now start it up, go to multiplayer and then use 'direct connect' (quickest way I think) and use: play.emc.gs as the address. Check what happens.

    If it worked then there was something odd in your previous program folder. In that case I suggest that you move the stuff you want to keep to the new folder, but be careful that you only move stuff around which can't hinder your game (like screenshots and/or resource packs).

    If this doesn't change anything then there's some very peculiar problem on your end.

    Warning: Windows won't allow you to rename the folder back to .minecraft from the GUI. That's because regular Windows filenames have a name and an extension (like textfile.txt) and just using .minecraft makes Windows think that you're trying to give a file only an extension without a name.

    You can solve this in several ways, but the easiest is to simply clean out the newly created .minecraft folder and then copy (or move) all the contents from your previous (renamed) folder back.

    Hope this can help sort some things out.
  11. Good idea, but there's one thing I'd do a little different; instead of renaming it, make a new folder there (= in the \roaming folder), call it bloob or dotminecraft backup or whatever, and just move the .minecraft in there. This way you won't have any problems if you decide to reuse the old .minecraft. :)

    I hope you're able to solve your problems soon, and I unfortunately cannot think of any other possible solutions. :/
    JustCallMe_Bunni and ShelLuser like this.