No Sound...

Discussion in 'General Minecraft Discussion' started by Slvr, Mar 15, 2016.

  1. So, ever since I played Minecraft on the computer (from about 1.8.7+ - before that I was an Xbox minecrafter :p) I would sometimes get an error in game where I would hear no sound. In 1.8.x, I could fix that just by pressing f3+s, but now, in 1.9, it seems to come and go randomly and f3+s doesn't do anything. Does anyone else get this?

    I did read about a bug reported for some Minecraft 1.9 snapshots where sound and subtitles both wouldn't work, but I don't think it was reported to still be the case for the full release.

    Just now, I restarted Minecraft 4 times before sound worked in 1.9. It seems so random, I really don't understand it, haha.
  2. Go into your volume mixer (if you have windows) and see if it is listed there. I had that problem a while back where it wouldent even list it.
    607, tinkao and AverageWalrus like this.
  3. Sometimes restarting your computer works too. I have this problem every now and then and this always seems to fix it.
    607 and ShelLuser like this.
  4. yes, would like to add, as sometimes if your audio switches devices, it can sometimes get suck on the one it switched to. Either restart client, or PC.
    607 likes this.
  5. Ah, okay. Thanks guys!
    Seems to happen a lot more frequently with 1.9, but I could just be imagining things. :D
  6. Best Minecraft Servers

    Works (almost) everytime ;)
    khixan, 607, Patr1cV and 1 other person like this.
  7. Also happens occasionally on my end, the solution is always to restart the game.
  8. I'd have this problem when I would pull on my headset cord and the sound adapter would come out of the usb port partially and kill the sound. I'd push it back in and I have no sound, restarting the game fixes that.
  9. Do you use Skype by any chance?
  10. Key word there: almost.
    I did a test earlier today and after restarting the game six times, I got sound back. It came back around after restarting the launcher 4 times (after going out again). And when it went out a third time, I attempted to restart the computer..which made no difference.

    My friend complains about this, though I haven't experienced it.


    It does seem the only fix is to just restart, though personally I miss the less annoying f3+s option. But that's just my two cents... XD
  11. Does this happen with other programs too?
  12. Hate to be bumping a thread from March, but the issue has started again, and this time it's not an issue with startup.

    I'll randomly be playing and then sound just ..... stops.

    Here is the output the game gives me:

    This being from my alt. Slvr's output is almost exactly the same but contains some chat from nearby players so I just used my alt's logs.
    EDIT: f3+t has helped in the past but isn't working with this one.
  13. Well, I'll reiterate my comment from before.

    Your best bet is to shut down your computer, then turn it back on. Don't restart because I doesn't have the same effect as the shut down. Idk what could be causing it though.
  14. I get this too. I've been getting it for years. Nothing has ever fixed it :p
  15. That log you listed shows that your minecraft install is broken, it also showed that sound didn't work from the get-go. Do you have a log where the sound shuts off halfway through playing?.

    Try removing the profile and re-creating it to get a fresh install of minecraft. Also ensure you've got an up to date java version installed.
  16. There was a bug in 1.8 similar to this. One of my chests would stop making sounds at random.
    It doesnt seem to happen anymore since 1.9 came out though...
  17. 1. While restarting the entire computer may fix it, I don't think I'm into restarting my computer every five minutes to make it work.

    2. I'll try remaking the profile, that seems like a good idea.

    3. I don't know if I have the most up to date version of java, but I know I updated it not long ago.

    4. Issue seems to have randomly vanished, and isn't happening anymore. The log there is from one where sound stopped playing suddenly, but perhaps pressing f3+t messed with the logs or something. Either way, the issue hasn't happened since earlier today where it happened thrice and I do not have a log with me not pressing f3+t... if this happens again though I'll remember to Not press that and give only the game's output.

    This bug doesn't make the game unplayable, especially with subtitles, but it is a bit frustrating.