Mob Heads Broken?

Discussion in 'Empire Help & Support' started by horrid1999, Apr 24, 2014.

  1. My collection of all mob heads was proudly displayed on my wall, but I've had to take it down.
    Why, you ask?
    Because all the mob heads besides the standard 4 have turned into Steve, and won't turn back!
    I first thought that it was a recent change to the code of the heads or something, but I just got a brand new slime head from a slime, and it was Steve!

    So, are mob heads broken?
  2. Use 1.7.9, make sure you have re-logged, they should eventually turn back to the heads they were.

    I had all my player heads as Steve until I updated.

    It is because Mojang now uses something else to read heads, or something like that... I could not say for definite, but I read something, somewhere, that said we would need to be on the latest for the heads to work.
  3. Well, that worked :p
    Thanks for the quick reply!
    FDNY21 likes this.
  4. yes heads will not render correctly unless you use 1.7.9.

    Mojang changed how heads work, and we allow older clients to connect but buggy skins.
    horrid1999 and FDNY21 like this.
  5. I guess my problem was that I didn't know we could connect with the new version yet.
    Must've missed that memo...
  6. I had this problem with mob heads also, but I was already running 1.7.9

    Placing the heads, then re-logging fixed the problem. Thanks FDNY21.

    If I break the heads and place them again, Steve. Re-logging again fixed again.
    I didn't wait very long and placing them so I don't know if after awhile they would have been fixed without re-logging.

    Hope this is helpful info if anyone is having this issue too.
  7. It apparently is a client bug and spigot has a fix ready we will update to soon.
  8. Good to know, got scared that my head wall was broken >.>
  9. thinks FDNY21 I also have some heads.... (5dc) on my collection
    FDNY21 likes this.
  10. I am running 1.7.9 for a while now, and heads are all steves. Did I do something wrong?
  11. Wait for server update.
    SkyDragonv8 likes this.
  12. Apparently you did nothing wrong. Until this is fixed, you can try what worked for FDNY21, myself, and others. Place the heads. Log out. Log back in. If you remove the heads and place them somewhere else, try logging out and back on again. This seems to make them appear correctly for the time being.
    FDNY21 likes this.