I Must Be In My Own Group?

Discussion in 'Empire Help & Support' started by azoundria, Mar 12, 2016.

  1. I was trying to attack a zombie pigman in the overworld on SMP5.

    It repeatedly gave me the message
    "You must be in azoundria's group to attack this monster. It will be unclaimed in 2 minutes XX seconds."
    607 and ShelLuser like this.
  2. It happens when someone else creates a group, then they leave. Unfortunately, that group seems to exist after they leave. I was able to get the same result when creating a group and inviting azoundria4. Then I invite myself, attack a monster, and leave.

    It says I need to be in azoundria4's group. So then in azoundria4 I invite myself. And still I can't attack the monster.
    607 and ShelLuser like this.
  3. Odd situation... Being able to recreate the problem perhaps can lead to a solution. Sorry I have no further information to help resolve...
  4. It's fine. I appreciate your help. I'm not sure the exact sequence to reproduce it but it happened to me multiple times.
  5. Well, this sounds as a very likely issue to me. I know that groups have extra protection around them, so if a group attacks a mini boss then that mini boss becomes their "property" for an x amount of time (I believe 3 - 5 minutes) so that others cannot attack it.

    The reason behind it is because other players might be on different difficulty settings. So if you try to get Momentus at difficulty 8 and some random stranger comes along with difficulty 2 then that could seriously affect the chances of good drops. So that part is covered.

    As to groups: yes, you can have your own one-man group when the others leave. If you want to get rid of that group entirely you need to use: /gr leave.

    But having said that: this definitely sounds like a bug to me because once your fellow players leave the group then it becomes your group. Just try to leave it, it'll mention that "you left your group". I'll also try to reproduce these issues later on and if I'm right then it might be best to message Aikar directly (I usually PM all the developers with bugs because they're a team after all).

    I'll get back to you.
    607 likes this.
  6. I was mining happily underground one day when suddenly I was teleported above ground into the middle of a groups battle with a momentus. I was not in their group, had no idea that momentus was above me and took some serious damage trying to get away. But I was not in their group. Quite the shocker as I was just out in my knock around armour not ready for battle.
    ShelLuser likes this.
  7. This is (or was) a known issue. I don't know the current status from mind but I do know that several players have mentioned this before; Momentus attacking players outside the group he's facing.

    It is an issue because you basically can't defend yourself, not even to get away, which could turn into a highly unfair situation :confused:
    607, cadgamer101 and Acemox2k like this.
  8. I've had this happen to me on a number of occasions. It's terrible. Especially when you can't get away, and are taking heavy damage and you just can't...well...do anything really other than die and hope you don't lose your stuff.
    Acemox2k and 607 like this.
  9. Does this issue have its own thread? Not that I think it can't be mentioned here, but I think it's more likely to be fixed if it has a thread dedicated to it instead of only being documented in a thread made for another issue.
    Acemox2k likes this.
  10. I felt it had a relation to the "I was not part of some other group" aspect. You never know when some tidbit of information that is similar in nature might help in the programing.

    The main difference is that in my situation their group was actively fighting the momentus and I got sucked in but could not join in. I just wanted out but it treated me like I was in their group as far as targeting me but not letting me fight and share in rewards.

    If it is wrong post spot my bad:confused: just thought it might help.
    ShelLuser likes this.
  11. I distinctly remember at the time I did try to leave. Even after it said I was not part of a group the issue persisted and I could not attack the zombie pigman.

    Having groups affect who can attack minibosses seems fine, but when they affect vanilla mobs, that's going too far in my opinion.
  12. Is it possible that there was still someone else part of the group? Someone who never left for example?

    Reason I ask: I've tried to reproduce this issue with my ALT. I could reproduce the error message, but only when I attacked a mob while in the group, then left it and then attacked again. I tried it back and forth between GripCEO and myself but nothing so far:

    Best Minecraft Servers

    What I tried so far:

    GC invited me, he attacked a mob, I left, he attacked again; no problem.
    GC invited me, he attacked a mob, I left, I attacked again; error.
    GC invited me, I attacked a mob, he left, he attacked again; error.
    GC invited me, I attacked a mob, he left, I attacked again; no problem.
    GC invited me, I attacked a mob, I left, he attacked again; no problem.
    GC invited me, I attacked a mob, I left, I attacked again; error.

    I still have some options left, and I also intend to try this with a pigman as well. But so far I haven't been able to reproduce issues; all the moments I triggered an error it was fully as expected.
    607 likes this.
  13. I was in a group Sunday. Not the same problem, but when the other members left I was getting messages as if I were still in the group while I was checking the Forums. I don't like the idea of a Group having mob ownership in the first place, but once there is only one person left it is no longer a group. The last person should be dropped out by default, and the group dissolved along with any residual effects like this.
    ShelLuser likes this.
  14. I thought something like I was in two groups, one which I actually had control of, and another which was started by my friend who went offline that I inherited.

    Even though they were both "azoundria's group" the other one I could not join again.