Beacon GUI not working

Discussion in 'Empire Help & Support' started by Unoski, Apr 18, 2016.

  1. Best Minecraft Servers

    I have a level 3 beacon that just won't let me do anything with it. The beam is up and everything.
  2. Okay. This annoyed me so much, since I used to have beacons on 3 of my old residences. I had all of the iron blocks and no blocks were blocking the beacon. I opened up the GUI and bam. Nothing happened. I asked other players and it worked for them. I even asked staff to help, but it also worked for them. I felt so stupid. I abandoned using beacons after that incident, but I forgot to post a thread about it. Someone smart answer the problem. :)
  3. Yeah I hate this thing. To fix:
    • Relogg
    • Break and replace
    ShelLuser and JesusPower2 like this.
  4. Pretty much what he said. Force a block update by replacing the beacon or part of the pyramid.
    ShelLuser and OriginalScuf like this.
  5. I still come across this annoying bug, when I'm out and about in the wild mining away. Though you actually don't even have to break and replace it. Just keep right-clicking until it appears normal - works for me every time and my pickaxe stays happy longer. :p
    ~ Just saying
  6. yeah if you keep going to the gui eventually it will work correctly
  7. solution: wait like 5 seconds, make sure you arent lagging and right click again
    ShelLuser and Ezebe like this.