[1.19.x] Empire Minecraft Utilities Mod

Discussion in 'General Minecraft Discussion' started by triphora, Sep 5, 2021.

  1. sadly, i use xareo's minimap. But i will give a try about voxel map if i have time
  2. Both have some kind of integrations :)
  3. did u mean it same as voxelmap? I saved all of thing into xareo's map and don't want lose waypoint and chunk load
  4. Currently, the map renaming is not enabled in Xaero's because it crashes for reasons I'm not sure of. Everything there is commented out.
  5. This mod requires architectury, right?
    Just FYI for everyone, since I just happen to be reinstalling minecraft today. Architectury just released V 3.3.6 or something, but it just crashes the game. get V 3.3.4 instead.
    wafflecoffee likes this.
  6. I have tried putting utilities into the new 1.18 today.
    Getting error messages mentioning architectury missing. Is this something that I missed downloading or missing from the mod.

    Fabric and the apilibrary already installed.
  7. https://www.curseforge.com/minecraft/mc-mods/architectury-fabric

    I haven't downloaded 3.3.4 yet, but I know trying to the newest version of architectury results in my client crashing. It has kind of put me off of installing the mod. Just need to build up motivation to download 3.3.4.
    wafflecoffee likes this.
  8. v3.4.9 of Architectury crashes? That should've been fixed ages ago...
    I'll try and see if I can remove the dependency on Arch API.
    Unoski likes this.
  9. I'll try my hand at it again later today to make sure it isn't working.
  10. Something I've noticed is that vaults don't use my texture pack for the vault UI. I assume this is due to the fact that emcutils includes a dark mode vault UI option. I'm curious if it's possible to add an additional option that's "default" and pulls the UI look from the texture pack instead?
  11. Theoretically, yes. However, the vault texture that the mod uses is 9x7, and almost no texture pack has a 9x7 chest texture included - usually only 9x1 through 9x6.
    Ryko369 likes this.
  12. Ah, that makes sense.
  13. Not really sure what the problem was. I wound up removing fabric loader and api from the .Minecraft folder and mod folder. To the point where I got a clean download and install the 2nd time and stuff worked much better. (This was right after I made the above comment)

    Last 2 updates I moved the old version folder to let Minecraft download a fresh game instance for the update, but I didn't this time, just pulled the mods folder. Must have been a coal ore mucking about in the Fabric and causing chaos, glad it's been cleaned up. Now just waiting on Voxel maps.... Totally miss my map :‑X
  14. Is there any mod in this modpack that makes Optifine not work?

    I've got optifine in my mods folder but somehow it doesnt show up/activate in-game
  15. Yes, almost all of the mods are incompatible with OptiFine. See https://waffle.coffee/optifine; OptiFine is pretty bad for Fabric 1.16+ and this mod has all of the alternatives while still giving the majority of the features :)
  16. If you still want to use optifine, you can use optifabric to make it work in the fabric loader. However keep in mind optifine will still likely not be compatible with many of waffle's modpack mods, like sodium, lithium, ect. Waffle's opinion will be biased when it comes to optifine, so if you need help with it, feel free to ask me.
  17. I'll have a look, thanks!
  18. This mod crashes Minecraft upon load due to an incompatibility with Voxelmap for me.
  19. I'm using Fabric-2.40-beta2, and as I've already told you, none of the features seem to be on. Minecraft loads, doesn't crash because of it, but none if the mod's utility or functionality works. Here is my modlist, if it helps... hope this can be fixed!

  20. I was getting this too, with that random discord guy's version of voxelmap. Honestly not sure what the best course of action is there, as it seems a little sketchy. I'm personally just gonna keep using Xaero's for the moment.
    wafflecoffee likes this.