Will not stop crashing

Discussion in 'Empire Help & Support' started by ThaKloned, May 6, 2016.

Thread Status:
Not open for further replies.
  1. Really getting annoyed with this thing.

    Logs:

    ---- Minecraft Crash Report ----
    // Who set us up the TNT?

    Time: 5/6/16 7:44 PM
    Description: Unexpected error

    java.lang.IncompatibleClassChangeError: Found class com.mumfrey.liteloader.util.Input, but interface was expected
    at net.eq2online.macros.input.InputHandlerModuleJInput.<init>(InputHandlerModuleJInput.java:90)
    at net.eq2online.macros.core.MacroModCore.initInputHandler(MacroModCore.java:365)
    at net.eq2online.macros.core.MacroModCore.onTickInGUI(MacroModCore.java:844)
    at net.eq2online.macros.LiteModMacros.onTick(LiteModMacros.java:127)
    at com.mumfrey.liteloader.core.event.HandlerList$Tickable9.onTick(HandlerList$Tickable9.java:100)
    at com.mumfrey.liteloader.client.LiteLoaderEventBrokerClient.onTick(LiteLoaderEventBrokerClient.java:419)
    at com.mumfrey.liteloader.client.CallbackProxyClient.onTick(CallbackProxyClient.java:70)
    at com.mumfrey.liteloader.core.event.EventProxy.$event00005(EventProxy.java:216)
    at bsu.as(SourceFile:903)
    at bsu.a(SourceFile:314)
    at net.minecraft.client.main.Main.main(SourceFile:120)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.8
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 161685896 bytes (154 MB) / 511705088 bytes (488 MB) up to 954728448 bytes (910 MB)
    Mod Pack: 1.8-SNAPSHOT-r372-b53-2015-09-09_11-36-17
    LiteLoader Mods: 3 loaded mod(s)
    - Macro / Keybind Mod version 0.11.1 beta 1
    - VoxelMap version 1.6.7
    - LiteModWDL version 1.8
    LaunchWrapper: 11 active transformer(s)
    - Transformer: com.mumfrey.liteloader.transformers.event.EventProxyTransformer
    - Transformer: com.mumfrey.liteloader.launch.LiteLoaderTransformer
    - Transformer: com.mumfrey.liteloader.client.transformers.CrashReportTransformer
    - Transformer: com.thevoxelbox.voxelmap.litemod.VoxelMapTransformer
    - Transformer: wdl.litemod.EventTransformerWDL
    - Transformer: com.mumfrey.liteloader.transformers.event.EventTransformer
    - Transformer: com.mumfrey.liteloader.common.transformers.LiteLoaderPacketTransformer
    - Transformer: com.mumfrey.liteloader.client.transformers.LiteLoaderEventInjectionTransformer
    - Transformer: com.mumfrey.liteloader.client.transformers.MinecraftTransformer
    - Transformer: net.eq2online.macros.input.InputHandlerInjector
    - Transformer: com.mumfrey.liteloader.transformers.event.json.ModEventInjectionTransformer
    JVM Flags: 2 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    Launched Version: 1.8
    LWJGL: 2.9.1
    OpenGL: GeForce GTX 650/PCIe/SSE2 GL version 4.5.0 NVIDIA 365.10, NVIDIA Corporation
    GL Caps: Using GL 1.3 multitexturing.
    Using GL 1.3 texture combiners.
    Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
    Shaders are available because OpenGL 2.1 is supported.
    VBOs are available because OpenGL 1.5 is supported.

    Using VBOs: No
    Is Modded: Definitely; Client brand changed to 'LiteLoader'
    Type: Client (map_client.txt)
    Resource Packs: []
    Current Language: English (US)
    Profiler Position: N/A (disabled)


    Any ideas? Fresh Windows install, fresh game install, works fine without mods. Just using liteloader, world downloader, voxelmap & macro mod. Worked perfectly before.
  2. Try pulling macro file right out of mod folder and boot again?
  3. Is that the one causing issues?

    EDIT: OK tried that and it loaded. Problem is I need the macro mod lol How can it work fine then not anymore!?
  4. Your log says vbos is off. I was having alot of issues and turning vbos on fixed them... maybe try it? Cant hurt to try.
  5. Got it working now. Tried a different download link for macromod. PCs sometimes....
  6. Glad you got it sorted out. :) But about that last statememt..: it's not hardware that's messing up, hardware always does what it's supposed to do. Software on the other hand... software is a bit like weather forecasts, they usually do fairly well, but sometimes they mess up royally. :p
    iKloned likes this.
  7. Best Minecraft Servers
  8. Closing thread at the request of the initial poster.
Thread Status:
Not open for further replies.