forge 1.12.2 crashing on launcher

Discussion in 'General Minecraft Discussion' started by TuckerAmbr, Sep 29, 2017.

  1. Hmm, I have a newer version of lunatrius...maybe it is my forge. I will check that
  2. Try forge-1.12.2-14.23.0.2493-installer-win. It's what I am using and schematica is loading just fine.

    Files I grabbed were:
    LunatriusCore-1.12.1-1.2.0.41-universal
    Schematica-1.12.1-1.8.0.164-universal
  3. The game crashed whilst initializing game
    The game crashed whilst initializing game
    Error: java.lang.VerifyError: Inconsistent stackmap frames at branch target 21

    That with the recommended version same error on lastest also. :(
  4. Do you use Optifine? If so try taking that out of mods folder then try loading again. More often then not (for me) that was the issue. Then it's a case of trying earlier versions of forge until they all work together.
    cubefragment likes this.
  5. Nothing else is installed yet in the 1.12.2 mods folder
  6. So what mods are you using with forge? Maybe try the version just before the current one. If that works great, if not try the next one, etc. I've had to do this before and sooner or later you get the one that works for you.
  7. LOL, looks like it has to do with the recipebook but I could be wrong im not a tech here. :D

    ---- Minecraft Crash Report ----
    WARNING: coremods are present:
    Contact their authors BEFORE contacting forge
    // Surprise! Haha. Well, this is awkward.
    Time: 9/29/17 9:53 AM
    Description: Initializing game
    java.lang.VerifyError: Inconsistent stackmap frames at branch target 21
    Exception Details:
    Location:
    Config.getWorldServer()Lnet/minecraft/network/play/client/CPacketCreativeInventoryAction; @21: getstatic
    Reason:
    Type 'net/minecraft/client/gui/recipebook/GuiButtonRecipeTab' (current frame, locals[0]) is not assignable to 'net/minecraft/item/ItemSlab' (stack map, locals[0])
    Current Frame:
    bci: @16
    flags: { }
    locals: { 'net/minecraft/client/gui/recipebook/GuiButtonRecipeTab' }
    stack: { 'net/minecraft/client/gui/recipebook/GuiButtonRecipeTab' }
    Stackmap Frame:
    bci: @21
    flags: { }
    locals: { 'net/minecraft/item/ItemSlab' }
    stack: { }
    Bytecode:
    0x0000000: b200 78c7 0005 01b0 b200 78b4 050f 4b2a
    0x0000010: c700 0501 b0b2 0078 b605 139a 0005 01b0
    0x0000020: b200 78b6 0516 4c2b c700 0501 b02a b405
    0x0000030: 1b4d 2cc7 0005 01b0 2cb6 0520 4e2b 2db6
    0x0000040: 0524 b605 273a 0419 04b0 3a04 01b0
    Exception Handler Table:
    bci [61, 73] => handler: 74
    Stackmap Table:
    same_frame(@8)
    append_frame(@21,Object[#1297])
    same_frame(@32)
    append_frame(@45,Object[#1304])
    append_frame(@56,Object[#1309])
    full_frame(@74,{Object[#1297],Object[#1304],Object[#1309],Object[#1314]},{Object[#1291]})
    at java.lang.Class.getDeclaredFields0(Native Method)
    at java.lang.Class.privateGetDeclaredFields(Class.java:2575)
    at java.lang.Class.getField0(Class.java:2967)
    at java.lang.Class.getField(Class.java:1693)
    at net.minecraftforge.fml.client.FMLClientHandler.detectOptifine(FMLClientHandler.java:305)
    at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:211)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:466)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:377)
    at net.minecraft.client.main.Main.main(SourceFile:123)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------
    -- Head --
    Thread: Client thread
    Stacktrace:
    at java.lang.Class.getDeclaredFields0(Native Method)
    at java.lang.Class.privateGetDeclaredFields(Class.java:2575)
    at java.lang.Class.getField0(Class.java:2967)
    at java.lang.Class.getField(Class.java:1693)
    at net.minecraftforge.fml.client.FMLClientHandler.detectOptifine(FMLClientHandler.java:305)
    at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:211)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:466)
    -- Initialization --
    Details:
    Stacktrace:
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:377)
    at net.minecraft.client.main.Main.main(SourceFile:123)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    -- System Details --
    Details:
    Minecraft Version: 1.12.2
    Operating System: Windows 7 (amd64) version 6.1
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 144059656 bytes (137 MB) / 255066112 bytes (243 MB) up to 1060372480 bytes (1011 MB)
    JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML:
    Loaded coremods (and transformers):
    Launched Version: 1.12.2-forge1.12.2-14.23.0.2491
    LWJGL: 2.9.4
    OpenGL: GeForce GTX 760/PCIe/SSE2 GL version 4.5.0 NVIDIA 382.05, NVIDIA Corporation
    GL Caps: Using GL 1.3 multitexturing.
    Using GL 1.3 texture combiners.
    Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
    Shaders are available because OpenGL 2.1 is supported.
    VBOs are available because OpenGL 1.5 is supported.
    Using VBOs: Yes
    Is Modded: Definitely; Client brand changed to 'fml,forge'
    Type: Client (map_client.txt)
    Resource Packs: Faithful 1.11.2-rv1
    Current Language: ~~ERROR~~ NullPointerException: null
    Profiler Position: N/A (disabled)
    CPU: 4x Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz
  8. Have you tried running the game without mods first? Very odd that the recipe book on it's own would be the issue. I know in previous versions if you had not downloaded the latest version yet then mods would not load properly. I don't think that is an issue any longer with the new loader. But ya try just loading vanilla first then work from there.
    cubefragment likes this.
  9. Yep did that first thing , always run it before installing mods
    ThaKloned likes this.
  10. Figured :p So what mods are you using?
    cubefragment likes this.
  11. Got it to work, thanks guys!
    ShelLuser and ThaKloned like this.
  12. Ok got forge to work, had to run as Admin to get it to take correctly, added Opti-fin after that , no other mods yet. Haven't decide which one I want to use this time. :rolleyes:
    ShelLuser and ThaKloned like this.
  13. Not sure if this is an issue with anyone else, but seems the receipe book isn't showing up when you click a bench or open your inventory.

    NM, its the resourse pack I was using, disabled it and the book shows up.:D
    ShelLuser and ThaKloned like this.



  14. halp me Obi-Wan Kloned, you're my only hope
  15. That's odd because those are the exact ones I have installed as well. Did you go with the latest version of forge or the recommended? Because it worked for me when I installed the latest
  16. Perhaps I did recommend - I'll give the latest a try, thanks Phelps :)

    *edit/update - worked, thanks again!
    Phelps4 and cubefragment like this.
  17. The problem with map mods is, VoxelMap has - by far - the best way to detect when you switch worlds and not mess up maps.

    However, Forge and Liteloader have different ways of interfacing code with Minecraft, which basically means most forge mods will work with different sub-versions of MC that don't change the code the mod is working with, but LiteLoader mods will always need to be recompiled for new versions. I verified my own mods that are allowed on EMC, they all seem to work fine. Voxelmap, we'll just have to wait.
  18. This says "The mods listed can't run in Minecraft version 1.12". Quite sure you're running 1.12, not 1.12.2, and 1.12.1 mods won't load on that older MC version.
    Eviltoade likes this.