1.4.6 Anvil not working with equipment and books

Discussion in 'Empire Help & Support' started by crossbones, Dec 26, 2012.

  1. Hey everyone, due to the recent thorns and enchanted books update, I have decided to get back into the enchanting business. I was sad to see that I can't combine enchantments or enchant items with enchanted books on an anvil. Let me elaborate.

    Last night I was able to combine two sharpness IV swords together for a sharpness V, life was good. This morning I tried to make it an unbreaking III sharpness V sword with an enchanted book. It didn't work. And when I went to try and combine items, that didn't work either. Basically, the anvil doesn't work at all except for changing names of items.

    Has anyone else had this problem? This is causing me alot of trouble and I hope it gets fixed soon.
  2. I am having this exact same problem. Aikar said that there isn't really anything he can do to fix it, so we have to wait until the next update. :(
  3. Yeah...So much for my infinity power IV i wanted to upgrade with flame...
  4. Aikar can't fix it? I mean it seems to be working in SSP. Although I guess it could be a bukkit problem.
  5. I noticed this too, I tried to combine a eff 4 and unb 3 but the end product was just a unb 3.
  6. I just lost a Sweet Diamond Pick and 34 XP levels doing the exact same thing I did in the past, combining two Silk E2 U2 Picks to get one silk E3 U3 pick, only now I got the same pick back :(, so I lost a good pick and 34 XP levels.
    Please let me know when there is a fix.
  7. can we still repair things without loing the enhant?
  8. Yes qwerty, I was able to repair an enchanted item successfully.
  9. please do not use anvils till next update. found a bug and fixed it.
    M4nic_M1ner and cadgamer101 like this.
  10. Thanks, do you mean the daily reset ?
  11. That is why i allways look before i click :p
  12. It seemed to work 2 days ago, I was able to apply unbreaking 3 to enchanted swords.

    Yesterday, I've noticed that applying some enchantments takes more levels than shown in the dialog, like level 13 instead of level 9. If you have level high enough, you can successfully apply enchantment.

    Today, I've tried to apply efficiency 4 book to a new diamond pick.
    - both the anvil and the pick were new, unused
    - I did not check the resulting Item prior to taking it into the inventory, it might be that the dialog did not / does not display the enchantment
    After taking it out:
    - my xp levels were used / taken
    - the anvil went from new to "slightly damaged" just from this single use
    - the enchanted book has disappeared
    - the pick did not get the enchants


    Second problem: it seems that the enchantments a book can receive are limited. I've enchanted about 40 books, all with level 30, but I did not get any of the high enchantments like Sharpness 4, Power 4, Looting 3 or Fortune 3.

    Third problem: I've heard a report that efficiency 4 and/or 5 enchanted shovels and/or picks do not have the dig speed they should have, but I did not check that myself.

    Aikar: please let us know what we can try or do, if we can help testing;
    please let us know if there are bug reports and responses related to these problems.
    Thank you!
  13. Sweet it's fixed woot! Thanks Aikar you rock!
  14. Yes, it is fixed, I now get E3 U3 from combining two E2 U2 's Thanks Aikar :).
  15. So, combining my 2 picks is fixed, but when I try to combine a Dia Spade E4 with a U3 book, it seems to consume the XP, and then drops the original items.
    After logging on and off, the XP returns.
    So, I can no longer combine shovel and book, like I did in the recent past.
  16. And now I can combine those two, so as far as I can tell, the Anvil is working. Thanks.