[1.16.5] Updated Fabric Mods

Discussion in 'General Minecraft Discussion' started by wafflecoffee, Dec 19, 2020.

  1. Featuring the Empire Minecraft Utilities mod, made by GreenMeanie with help from yours truly!

    Don't want to update your Fabric mods? Let me do it for you! I set up this here modpack that downloads the latest of a predefined set of mods. This is an easier way to download one thing to get all of the mods included instead of having to download 40+ separate mods.

    Versions

    There are two versions of the pack.
    • Sodium (recommended): This pack is for those who want a few more mods. This is the pack I use personally. It includes some optional tools that very few people would actually utilise, such as Critical Orientation or WorldEditCUI, and it will prompt you at installation whether you wish to install these optional mods or not. It includes all of the performance-enhancing mods.
    • OptiFine: This pack is the same as the Sodium pack, but with OptiFine instead of some of the performance enhancing mods. This should only be used if you wish to use shaders.
    Installation

    To install the modpack, see the guide here; there are different sections depending if you use MultiMC or the default launcher.

    Mod List

    The mod list can be found here.
  2. Helpful list for those who are lazy on searching for all the mods they need.

    I updated all my mods and a new 1.16.4 multi mc instance, all ready to go a few days ago
    Fairly basic, only using easier crafting, fabric api, optifabric and optifine only because of connected textures :)


    at a later date I’ll more and likely install litematica etc
    wafflecoffee likes this.
  3. My experience with some of these mods:

    Xaero's Minimap I get stuttering when I spin around. Replaced with Voxelmap.

    Dynamic FPS FPS dropped to 1 despite Minecraft being, and staying, in foregound. Removed.

    Critical Flight Details What is with that green bar? Lacking decimals on the angle, the mod is about useless. The MiniHUD works much better. (I need that perfect 2.2 slope for maximum distance)

    Ok Zoomer I didn't even try this one. WI Zoom works for me.

    MiniHUD Nice 5zig standin, until 5zig gets updated to 1.16.
    wafflecoffee likes this.
  4. Strange, I've never had that issue. I would look into it but I've no way to reproduce it to report it.

    These are all fair assessments, thank you for your reviews :)
    jaqque likes this.
  5. Bump, updated mods and also added an OptiFine version :)
    Kryarias likes this.
  6. What does WorldEditCUI do? Isn't that map maker territory?
  7. It can be used in making subzones.
    Talechaser likes this.
  8. Bump, I've created separate "Minimal" and "Full" sets :)
    Unoski likes this.
  9. Just wanted to thank you for this thread. Been looking for an inventory sorter for fabric and thanks to you, I found it.
    wafflecoffee likes this.
  10. I tried out out Fabric launcher an your zips for the first time, but they end up crashing the client... any ideas as to why? it just says exit code 0
  11. Upload your latest.log after a crash to Pastebin please :)
  12. Don't update to 1.16.5 there are some bugs with smoothboot

    Just a warning may Just be me tho

    Nope looking at your post iv just seen you removed it
  13. Smooth Boot works fine with 1.16.5 for me, the only issues I've been having are with Light Overlay and Not Enough Crashes (ironically). If anyone else gets one of the Sodium packs and has issues with Smooth Boot, please let me know and I'll remove it; however, for the time being, it'll still be there.
  14. since the thread said 1.16.4, i downloaded that version of fabric. and it kept crash (even after i removed smoothboot

    i reinstalled fabric with 1.16.5 and it worked :)

    Code:
    [14:41:21] [ForkJoinPool-1-worker-1/WARN]: The mod "autoconfig1u" contains invalid entries in its mod json:
    - Unsupported root entry "$schema" at line 2 column 14
    [14:41:21] [main/FATAL]: A critical error occurred
    net.fabricmc.loader.discovery.ModResolutionException: Could not find required mod: hydrogen requires {minecraft @ [1.16.5]}
        at net.fabricmc.loader.discovery.ModResolver.findCompatibleSet(ModResolver.java:180) ~[fabric-loader-0.11.1.jar:?]
        at net.fabricmc.loader.discovery.ModResolver.resolve(ModResolver.java:787) ~[fabric-loader-0.11.1.jar:?]
        at net.fabricmc.loader.FabricLoader.setup(FabricLoader.java:211) ~[fabric-loader-0.11.1.jar:?]
        at net.fabricmc.loader.FabricLoader.load(FabricLoader.java:201) [fabric-loader-0.11.1.jar:?]
        at net.fabricmc.loader.launch.knot.Knot.init(Knot.java:126) [fabric-loader-0.11.1.jar:?]
        at net.fabricmc.loader.launch.knot.KnotClient.main(KnotClient.java:27) [fabric-loader-0.11.1.jar:?]
    Caused by: net.fabricmc.loader.util.sat4j.specs.ContradictionException: Creating Empty clause ?
        at net.fabricmc.loader.util.sat4j.minisat.constraints.cnf.Clauses.propagationCheck(Clauses.java:117) ~[fabric-loader-sat4j-2.3.5.4.jar:?]
        at net.fabricmc.loader.util.sat4j.minisat.constraints.cnf.Clauses.sanityCheck(Clauses.java:97) ~[fabric-loader-sat4j-2.3.5.4.jar:?]
        at net.fabricmc.loader.util.sat4j.minisat.constraints.MixedDataStructureDanielWL.createClause(MixedDataStructureDanielWL.java:81) ~[fabric-loader-sat4j-2.3.5.4.jar:?]
        at net.fabricmc.loader.util.sat4j.minisat.core.Solver.addClause(Solver.java:401) ~[fabric-loader-sat4j-2.3.5.4.jar:?]
        at net.fabricmc.loader.discovery.ModResolver.findCompatibleSet(ModResolver.java:177) ~[fabric-loader-0.11.1.jar:?]
        ... 5 more
    UltiPig likes this.
  15. Scratch the last bump-- the pack has been updated once again (just a few hours later) to add GreenMeanie's Empire Minecraft Utilities mod! I am glad to "debut" this mod Green's been working on for the past couple weeks, with a few QoL improvements specifically made for EMC. It's included in all packs :D
    UltiPig likes this.
  16. So, The Empire Utilities mod actually makes the shulker tooltips mod not work in the vault. Most likely because the Empire Utilities uses an old version of the vault. Just FYI
  17. Not an old version per se, it's recoded and client-side (old version was server-side). The dev is aware of the issue, though.
  18. Bump!
    There are now new installation procedures, and overall it's just a much cleaner system now, using the Packwiz format: the way it used to work was very difficult to maintain and was just... bad.
    With the new system, it's easier for both you and for me to maintain. Full instructions here :D
    Tuqueque likes this.