Vault broken

Discussion in 'Empire Help & Support' started by melodytune, Jan 10, 2013.

  1. Just a heads up, Vault is not working. It charges you but does not open. Couple different people tried it with the same outcome.
  2. Tried it, didn't work as well...
  3. Yeah, we got this error before (http://empireminecraft.com/threads/vault-is-broken.19182/) - not sure if it was ever fixed :/

    You're not a new player either, strange.

    Did it happen before the server update a few minutes ago? It has caused 1 bug to be re-introduced but that was fixed pretty quickly.
  4. Yeah, I read your enchanted pickaxe bug post, found it weird. Maybe the update made the bugs from 1.4.6 come back?
  5. It happened after the update. Yeah, I know how to use vault. =p Also asked in chat, others are having the same issue. I tried it three times. The third time after waiting some time. Its not a big deal, just wanted to let people know so they don't blow a bunch of money trying to open it, and so it comes to the attention of those who will fix it.
  6. It was, I let Aikar know though and he fixed it :) "The update reverted a few reverts" as Aikar said :p
  7. Deploying fix now... Seems I may of commited the one im working on updating vault... that wasnt the right one!
  8. Thanks, Aikar. :)
  9. Oh, Aikar...Ruining the economy and deploying half-done plugins...
    AlexHallon likes this.
  10. sorry bout that... I got really worried because that had so much potential to destroy peoples vaults... thankfully it didnt.

    been switching back and forth between branches of vault rewrite and mainline.. didnt know vault was last compile I did :/
    SoulPunisher likes this.
  11. I got nothing of that :)
  12. Basically he's saying he's been updating vault and working on other things like the dragon tombs, and has been switching back and forth. He compiled something, and must have thought it was the last thing he compiled, but instead it was vault...so he deployed the new vault rather than the current one :p

    Understand now? Probably not.
  13. (Anxiously awaits the accidental deployment of Dragon Tombs)
  14. The line that copies the .jar to the deploy folder has been commented out on dragon tomb cause I was tired of it sitting in my plugins folder :p
    Pab10S likes this.
  15. And its not even a new vault yet lol... the entire open function was commented out is why nothing happened.

    I have to convert the old vault before I can write code for the new vault :p
    SoulPunisher likes this.
  16. Best Minecraft Servers
    SoulPunisher likes this.
  17. He accidentally put the wrong thing in. Better? :)
    SoulPunisher likes this.
  18. I get it now! :p