Unable to log on to servers?

Discussion in 'Empire Help & Support' started by Duflet, May 17, 2016.

  1. My internet is fine, but whenever I open up the multiplayer screen, all the servers time out. I've tried closing and reopening, using a different account, and even restarting my computer. Help?
    JustAJarOfJam likes this.
  2. Restart your internet router. Even though everthing else is fine, this has been the case for me before.
  3. I'm not allowed to.
    JustAJarOfJam likes this.
  4. You can't just unplug it and plug it back in real quickly. No one would know.
  5. This is the best option
    Works for me
  6. Did you try turning your router off and on? (anyone get the reference?)
    WitherDoggie likes this.
  7. I mean not allowed as in having a very stubborn brother and a mother who will ground me if I do.
    JustAJarOfJam likes this.
  8. Sorry, but I had to.
    Best Minecraft Servers
    TamTamV and PeculiarPotato like this.
  9. Does your router have the option to restart it via the internet? Like mine does.
  10. See thats why I have admin powers to my router. If they got a problem with it... ban them!!!!
  11. Okay, just to be clear, I am not allowed to turn off and on/restart my router.
    JustAJarOfJam likes this.
  12. My mom doesn't even know how to use our router. So I have full powers over it.


    I don't know of another way then. :(
  13. Have you tried restarting your router?

    :mad:
  14. Just "trip" over the cord. Woops.
    Best Minecraft Servers
  15. Just ask your parents and brother nicely

    Such a hard task, I am stumped :p
  16. By this you mean you click the server and click connect, or just the main menu?

    Also, is your Java up-to-date?
  17. Java is up to date.

    On the title screen, I press the "multiplayer" button. All the servers do the "loading" thing for awhile, and then eventually gives me the "Cannot connect to server" message. Whenever I try to connect anyway, it times out. All other internet functions work just fine.
    JustAJarOfJam likes this.
  18. hi did u try using direct connect ?
    just wait it out most routers reset automatically at some point
  19. Direct connect does not work.
    JustAJarOfJam likes this.
  20. It's not your internet, as you are clearly able to post here. Try using a new directory.