Ubuntu Help (looks at Aikar)

Discussion in 'Empire Help & Support' started by xHaro_Der, Jul 8, 2014.

  1. So I got a new laptop, wiped it and installed Ubuntu 14.04 Trusty Tahr, wupee! Booted and all is well, but when I go to wireless it appears there is not a Broadcom wireless driver installed on it. I tried wired connection too, but it doesn't pick up my ethernet wire at all. I have literally used Ubuntu for the first time like an hour ago, so I don't know much and this is probably a really dumb problem. Help if you can, thanks. I can post any info off the terminal if you want to see my settings or whatever.

    EDIT - This just in, I'm looking at https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx and it looks like it matches my setup. I tried the method for "no internet" Trust Tahr version, putting the drivers on a USB and then moving it onto the laptop. On the page it says that then you need to run two command lines. I ran the first just fine, but the second one gives me random errors. I also noticed that when I boot up it gave me an error. I couldn't see it long enough to read it but it was something about b43-cutter which I noticed was included in the second command. Not sure what to do D:

    Problem fixed. For future reference, save yourself the hassle and don't get any Ubuntu other than Ubuntu GNOME, it will save you a lot of failure. None of the Ubuntu come with drivers installed, so you will need to use a wired connection with GNOME to install the wifi card drivers (Google it, super easy with wired connection, just open terminal and type in two commands). From there you can install whatever tweaks and edit any dohickeys to how you feel fit. Enjoy ;D
    607 and krysyyjane9191 like this.
  2. +1 for title
    Scorpio528, princebee and jrm531 like this.
  3. ^all of this
  4. What is the Make and model of the laptop.

    1. Does it have one of those stupid toggles ( I pry it off or superglue it in the ON position).
    2. Welcome to the Nix Party.
    3. The world hates the Broadcomm. But this is how I fixed it on my boxes.

    sudo apt-get install linux-headers-generic
    sudo apt-get install linux-headers-$(uname -r)
    sudo apt-get install --reinstall bcmwl-kernel-source
    sudo modprobe wl

    Think I left a msg on the board out at the ocean house, if this is the same person.
  5. Thanks for the help, but I wiped the laptop yet again and installed Ubuntu 14.04 GNOME, which installed the drivers alright. I'll make another post if I run into any other issues, but it works great for now :). Also my laptop is a Dell Latitude E6400, it comes with Windows but I wiped it since it only has 2 gigs of RAM I needed a lighter OS.
    What xD
  6. did you happen to not check the Install Restricted Extras? If so, go reinstall and checkbox it this time.
    porphos likes this.
  7. oh nice, I actually use GNOME desktop myself, so I can recommend it.
    Unity = bleh
    highlancer54 likes this.
  8. Alright, all my drivers are working nicely and I installed all necessities quite easily. Thanks everyone!
  9. http://screencloud.net/v/gEu2

    If you want this dock I have, do

    sudo apt-get install cairo-dock
    if you want to use that IRC client, do

    sudo apt-get install irssi screen
    then type this into a terminal:

    echo 'alias irc="screen -DURS irc irssi"' >> ~/.profile
    alias irc="screen -DURS irc irssi"
    This will set up an alias called 'irc' that opens the IRC client (and you can close the window but itll stay running, then type irc again to go back to it)

    This way you can then set it up to go on EMC IRC and be in there with us 24/7 (well as long as your pc is logged in with the app running)

    porphos likes this.
  10. I would if this was my gaming rig, but this is just my workstation/programming laptop. I may consider something similar on my normal rig. I already got Cairo and I love it, and I'm customizing all the boot logos and stuff now. I like how the OS is really flexible unlike Windows/Mac who are all like "oh, you dont like how we work, k go cry in the corner cuz guess what i put a padlock on it ;DDDDD!!!!!1111one"