[Tutorial] Installing Schematica & World Edit (Single Player)

Discussion in 'Miscellaneous' started by SnowyBearr, Jul 17, 2015.

  1. Probably not the best place to put this post, but didn't know where else to put it. This is a short video guide on how to install Schematica and World Edit for Single Player. World Edit is optional.

    Forge: http://files.minecraftforge.net/#Downloads
    Schematica: https://mods.io/mods/1008-schematica
    Lunatrius: https://mods.io/mods/1025-lunatriuscore

    -World Edit
    Lightloader: http://www.liteloader.com/download
    World Edit: http://minecraft.curseforge.com/mc-mods/225608-worldedit
    World Edit CUI: http://www.minecraftforum.net/forums/mapping-and-modding/minecraft-mods/1292886-worldeditcui

    World Edit is optional. World Edit CUI is also optional, you can use just plain World Edit without the display of selection if you wish. If you get World Edit but not World Edit CUI you do not need Lightloader.

    Extra Warning/Tip: Schematica is allowed on EMC, however the Print option built into the mod is not. This would be considered cheating and is a banable offense.

    Hope this helps. If you need further help just ask. Will make a guide on how to use both of these mods if anyone needs. They are very easy to use once you get the hang of it.
    ShelLuser, Roslyn, Penguinub and 8 others like this.
  2. Very helpful tutorial
    Ultimamaxx likes this.
  3. Glad it worked for ya. :D
    SEPTHEKID likes this.
  4. I downloaded and added forge but every time I click Play on the minecraft launcher it won't launch the game and the minecraft launcher appears again.
  5. Someone else had a similar problem. They were using Windows 8 but used the normal installer. Are you sure you got the right version?
  6. I'm using Windows 7 and I downloaded the normal installer so I don't think that's the problem. Although I am going to try downloading it again. My computer isn't very good so is it possible that it just can't handle forge?
  7. Shouldn't be a problem. Once you try again let me know if you still have an issue and we can see if we can figure it out. :)
  8. I tried it again and it gave the same result. Here is a picture of what the launcher does when I try to play.

    Best Minecraft Servers
  9. Would you take another screenshot of that error but scroll all the way to the top and all the way to the right? It has a nullpointer but I can't see what it's referencing. :p
  10. If the error message near the top is anything to go by, using the latest version of Java should be your first step.
    SEPTHEKID and SnowyBearr like this.
  11. Best Minecraft Servers

    I updated to Java 8 and received the same error.
  12. Do you have any other mods?
    SnowyBearr likes this.
  13. I have some in my mods folder, I'll try taking them out.

    Edit: It worked! I took the mods out and minecraft and forge launched normally! Thanks for the help!
    SEPTHEKID likes this.
  14. Hey snowy, looking to use schematica for the chisel me this comp but can't get it to work, whenever I try to launch it goes through the forge loading screen then white... and white.... and more white