[Mods] Minecraft Forge Help

Discussion in 'General Minecraft Discussion' started by PenguinDJ, Mar 23, 2013.

  1. Hey Empire!

    I want to install mods, mainly DivineRPG. To install that mod, I need Minecraft Forge. I want to use Magic Launcher to switch between mods easily. When I try to add MCForge, it says it's not compatible with minecraft.jar. Any help? I've looked it up and can't find anything.

    607 likes this.
  2. Well, I have exactly the same problem!
    I hope you(or we)can find help!
  3. PandasEatRamen likes this.
  4. Thanks chickeneer. I had the wrong version. Now all I have to do is wait for DivineRPG to update.