[Help] Need some modding help

Discussion in 'General Minecraft Discussion' started by PenguinDJ, Nov 23, 2015.

  1. Hello,

    So I've used Forge with LiteLoader for a few mods for a long time on 1.8, and that's worked fine. However, as I'm starting to play more 1.7 PvP servers (won my first off-EMC UHC today, woo!), I need to install some essential mods with Forge... and I can't figure out how to do that.

    I know how to install Forge and have done so for 1.8 and 1.7.10, and I dropped all of my mods in a "1.8" folder in .minecraft\mods and that works flawlessly. All of my 1.8 mods work.

    However, whenever I try to run Forge 1.7.10, the game crashes during launch. I've tried adding a 1.7.10 and 1.7 folder to .minecraft\mods with no luck. I'm crashing with two mods only, so I'm pretty sure it's an issue with mods of different versions being in the same folder.

    Any help in the right direction would be greatly appreciated. Thanks,

    Tahitan likes this.
  2. Have you taken out your 1.8 mods? :p
  3. I play on both 1.8 and 1.7.10 so that's not really an option here. :p
  4. Apple or Windows?
  5. Windows.
  6. All of your 1.7 mods must be the same version. So you need either all 1.7 or all 1.7.10 mods.
  7. Then, how i always do it is, go to %appdata% and go to my .minecraft folder, then go to mods,and remove all my old ones, then put in the new ones. Just make sure to switch forge versions :p
  8. They're all 1.7.10... it's just two of them.
    Huh? I can't do that with how often I switch versions. I know there's a way to do it without removing mods, I just don't know how...
  9. Take out the 1.8 mods, make a folder for them somewhere, put them in there. Put in your 1.7 mods in the mods folder. It should work.
  10. What mods are you using? I have re-created what you did and I was able to get it to work perfectly.
  11. For 1.8, Schematica, ArmorStatusHUD, StatusEffectHUD, bspkrs core, damage indicators, lunatrius core, voxel map, optifine, and Batty's coordinates

    For 1.7.10, OptiFine and Batty's Coords
  12. This is what you do: add 2 versions of the game. People already hinted at it above: some mods are no longer being developed for 1.7.10 and have moved onto 1.8. You can't use those in a 1.7 environment. So you need to make sure to download the 1.7 variant.

    Here's where things get tricky: Minecraft, like most software, isn't forward compatible. Meaning that a 1.7 mod will likely be able to exist within a 1.8 client (it simply won't work) but the other way around can be a sure way to crash it. Because the new mod will try to 'do' things which Minecraft doesn't expect nor can't control.

    So here's what you do: create a new profile in the launcher and make sure you can recognize it as being 1.7. Then edit that profile and check the "Game Directory" argument, it's right at the top. Point that to another directory (maybe .minecraft17 ?) and then place all your 1.7 plugins in the mod folder there.

    That makes sure that whenever you launch 1.7 you'll use 1.7 mods and nothing else. And whenever you get back to 1.8 you'll be using 1.8 versions without the previous ones being present.