Empire Minecraft Utilities Mod

Discussion in 'General Minecraft Discussion' started by triphora, Sep 5, 2021.

  1. I have released v3.0.0-beta.1 Fabric/Forge which should fix this issue :)
    I have improved the way that compatible resource packs for the vault screen can be created in this latest release. Send me a link to what resource pack you use and I can create a corresponding addon - currently, the available addons in the resource packs screen are Vanilla Tweaks and Dark UI 32x (aka Faithful Dark UI).
    UltiPig likes this.
  2. Empire Minecraft Utilities v3.1.0 for Fabric has been released. This adds compatibility with the recent 1.18.2 Fabric port of JourneyMap. There's no 3.1.0 release for Forge because the integration is only on Fabric, though I might port it over eventually.
  3. HazardousCode likes this.
  4. Any chance for this to be upgraded to fabric? I can't seem to use QuiltedFabric due to incompatibility with some fabric mods I'm using.
  5. Could you send your logs? This is the thread on Quilt's forums that talks about all of the known incompatibilities.
  6. emcutils has been updated to 1.19.3 for the past two weeks! This new version fixes a plethora of bugs, including the cross-server teleportation and "Teleport to Residence" on minimaps not working.
    UltiPig likes this.
  7. Add this to Technic aswell when you update pls
  8. No thanks. Too complicated to explain why I'm not going to do that, but I'm not going to.
    UltiPig likes this.
  9. Version 5.1.1 has been released. You can find it here.

    This update reintroduces the styled nameplates above everyone's heads in-game. The ones that make your name blue if you're a diamond supporter, and will show the [Mod] after the name if the player is a moderator. It's pretty nice to have it back :)
    triphora likes this.
  10. Has already been updated to 1.20 for a few days now.
  11. error trying to run the Quilt installer:

    I had to go find a Quilt installer page from the website, https://quiltmc.org/en/install/client/
    (I didn't see a button for it on your link)
    I have the current Java. I chose client install. I tried the jar file and when trying to run the Quilt installer file I get the following error:

    Java Virtual Machine Launcher
    A Java Exception has Occurred

    *internet search tells me it might be a java version problem, or ?? something else.
    Any ideas?
    Fabric installer worked just fine the first try.
  12. Version 8.0.0 is now released for 1.20.4 - Forge and Fabric/Quilt. Let me know if there are issues with any feature.

    Fabric support has been reinstated because it has become clear that Fabric is remaining dominant over Quilt.
    KatydidBuild likes this.
  13. Thank you so, so much for this! I was trying to do this on my own and failing. I think my problems were down to not adding the VaultScreen to HandledScreens, ugh!

    Since you did not make a 1.20.2 version, I assume I could leap to 1.20.4 now and EMC will be ok with that because of Via Version or something similar?

    A few non-technical questions:
    1. Will you re-add quilt support if/when they catch up (if ever)?
    2. Not important to me, but curious: will you add Neoforge support?
    3. Generally, what mod loaders do you think will prevail in the long run?
  14. Yes, you can safely connect to EMC with 1.20.4.
    1. Fabric mods work on Quilt by default. I haven't tested it, but I have no reason to think that the Fabric version won't work on Quilt.
    2. If Architectury supports it, yes.
    3. The Minecraft modding sphere is so turbulent that I would likely be eating my words no matter what I say. So I'll bite my tongue and say that there's a good chance all of them have some sort of shot at sticking around. The important thing is to be flexible and willing to change, and if that ain't a life lesson, I don't know what is ;)
  15. 1.21 support is now available. Download for Fabric/Quilt and NeoForge.

    Forge support has been dropped because the build software I use to create the mod has itself dropped support for Forge. I decided to leapfrog directly to 1.21 instead of fixing the currently-broken 1.20 versions, since ViaVersion is a thing. If anyone really wants it, I can backport this version to 1.20.4.

    I have tested all features, and everything seems to work with the exception of the integration with Xaero's World Map. I recommend using JourneyMap instead.
    NickkG and PopTart_Flavored like this.