EMC 1.7

Discussion in 'Community Discussion' started by zervados, Nov 26, 2013.

  1. In case you did not know, EMC is available through the 1.7 launcher I noticed. Just a nice little warning. I am currently on it using Snapshot 13w48b
  2. I have my second client running on 1.7.2 - and it's not available ... EMC is on 1.6.4
  3. only available though emc.gs (fake 1.7)