[Bug?] Hitting mobs with fire aspect II swords doesn't work

Discussion in 'Empire Help & Support' started by frostyminerpete, Aug 9, 2016.

  1. Hey all, the title says it all, I was farming cows with a fire aspect two sword and nothing was happening.. not sure whats going on there.. it doesn't work for chickens either but by the looks of things works out side of town. I have animaldamage, ignite and combust flags on and it still won't work. Anyone able to shed some light on this?
    Thanks,
    -Pete
  2. If you have firespread off as a flag, then the animals on the residence wont get on fire

    edit did some testing and it doesnt work :confused: 1.9 bug?
    ShelLuser and Theomglover like this.
  3. Idk, was working fine for me till now, i'm on 1.10.2 client
  4. I believe animaldamage is the only flag that would need to be on in order to kill them. I think the firespread is only for things like making a fireplace inside a wooden house and having it NOT ignite the whole house.
    crazyminerpete likes this.
  5. I had animaldamage on aswell, still didn't work
  6. i cant find why it isnt working, maybe it is a bug
    crazyminerpete likes this.
  7. Tried 1.9.4 as well?

    EMC is currently still on 1.9, although you can connect with a 1.10 client the server doesn't support any of the new features just yet. Now, I'm not sure here but theoretically this can cause a few issues. Therefore the suggested version to connect is still 1.9.4.

    So it might be best to try with that version first. Anyway, I'll also try to reproduce this later today.
    crazyminerpete likes this.
  8. That is very weird :p
  9. I think Aikar did some work with this so in order for entities to catch fire the flag damage is required, which is a restricted flag that we cannot alter as players. When this happened my arrows wouldn't ignite anymore when they left my voter's bow, but they do now, perhaps another alteration was made.

    Edit (After I tested): My Arrows are on fire when they leave my voters bow and the animals don't catch fire when they're struck with the flaming arrow. Also when I strike one of my animals with my voter's sword, the animals don't catch fire either.

    This isn't a bug this was added, however I am kinda against it because it is a bit of an inconvenience. When I try to obtain steak from my cows and I just get beef, I need to cook the beef.
  10. In the mean time I can confirm that this has nothing to do with client versions. 1.9.4 or 1.10 makes no difference for me.
  11. Im using 1.10 client and it looks fine to me. Not sure whats wong here :/
  12. So when you chop cows you get steak? And pigs get you roasted porkchop? That sounds interesting.
  13. In the wild that's what happens but in town you get raw meat because in order to get cooked meat the animal has to die via fire, damage flag is required Aikar says.
    ShelLuser likes this.
  14. that wasnt how it was before =/
  15. Also happens to me.

    I'm using 1.9.4 and killing cows with an Iron Voters Sword, but no fire damage is inflicted.
  16. I find that quite strange, that wasn't the case before. I didn't need any flags, just hitting cows with fire aspect worked
  17. Has anyone confirmed that the damage flag does indeed cook the beef? Also, is that the only flag needed for it to work? I need to get me some beef off of my res.
  18. The damage flag is a restricted flag and the flag is disabled in town, that's how we can't take any damage in town. You can't alter it on your own res and the staff won't alter it for you.
  19. So how can I kill my cattle and cook the beef? This is an epic bug.
  20. i noticed this bug past week and told staff
    they got a SS involved and they said it was a bug

    so for everyone on this thread :p
    it is a known bug and i think we just need to wait for someone to fix it :)
    eikar is props just busy a lot in real life
    lets just give them some time :)