World Downloader wont save parts of maps

Discussion in 'Empire Help & Support' started by NZScruffy, Nov 20, 2014.

  1. Hi all. Technically not really an EMC problem perhaps. But a problem specific to EMC.

    Using mod: World Downloader for minecraft 1.7.2

    I download my overworld areas just fine. But in the nether, some areas are not downloading. I click download world, then move around to get all the bits I need, then stop download (and download world again, due to a bug with 1.7.2 world downloader it doesn't save until you start download again). It says 'still saving' and never ever stops.

    The region files I get if i just disconnect, are incomplete, missing in particular the areas of the world I have modified.

    Any have this issue? And anyone know how to fix it? (only seems to happen to me in the nether).
    colepuncher likes this.
  2. You might want to google this issue, or look up tutorials on youtube....
  3. I would usually just download in increments - or preload the chunks ... And singleplayer-world edit the regions together ... Making a local server using async world edit would be better, though.
    NZScruffy likes this.
  4. lol naturally that's the first thing I did. But I cannot find this issue anywhere.

    umm.. not sure what you mean there, download in increments. I'll have a look at that. Even if I simply stand in one place and start/stop the download, still doesn't work. It seems to be any chunk that has had player changes wont' save. I wonder if it's due to custom mobs or content? Might try turning off mobs or something.
  5. Happening to me too. Tried to download parts of my wild town so I could make some nice Chunky shots, but it say's "Still saving" when I go into the menu.
    NZScruffy likes this.
  6. I was meaning increments as in - download the world while standing in different locations...(if it's not getting the whole region at once)

    if you have singleplayer commands (world edit for singleplayer) ...use the following commands:

    to select position 1) //pos1
    to select position 2) //pos2
    to copy the area) //copy ...(remember the location where you're standing - that's important)
    to save the schematic aka selection) //schematic save (name)

    <repeat the above steps with different world downloads ... by going onto that particular singleplayer world... and selecting the successfully loaded areas>

    Afterwards - go onto a new world (or world you'd like to edit) ... and use the following commands:

    to load the schematic) //schematic load (name)
    to paste the selection) //paste -a ...(remember where you were standing, and the direction you were facing when you copied - that's important)

    If the areas are way big - don't use singleplayer command ... make a local server and get 2 plugins and 2 mod:


    (to visually see the world edit selections - you'll need the two mods below) but not needed to do the commands
    ^ requires liteloader ...

    the commands for local server are the same as in singleplayer, but async stops world edit commands from happening - and then releases it in increments (not all at once) so it's less likely to crash things. :)

    use //paste -a ... instead of //paste ...this allows for air to be removed when you paste, so air doesn't replace the blocks in the area ... and also it's less blocks that have to be queued and rendered.
    NZScruffy likes this.
  7. Ah i see. it's a good idea. But the problem is that it's the same area of the world that never saves. I get surrounding areas save every time, but never the area that was modified by a player. Not sure why.

    I don't have asyncWE, so i might get that. though for now, haven't done any huge editing. lol