updating trouble

Discussion in 'Empire Help & Support' started by gcutrara, Jul 30, 2013.

  1. My mac is very old and I need to get a $20 update so I can get the new Java.... I can't update to the 1.6 launcher because of this. So, I cannot play on EMC [unless I can update (yes, I am cheap for not buying the updated software)]:p
  2. Java doesn't cost money to update...just go to www.java.com/download and click Download Now. Or are you saying your computer isn't able to handle/doesn't support the new update, and you need $20 to buy some kind of new part or OS update?
  3. even if your being serious about not being able to update (idk if your trolling or telling the truth) but the fact it says your a new member and $20 is the exact amount for getting the ability to use TNT it makes you look suspicious (you might actually need help idk much about macs but just saying suspicion)