Something with either Java or Minecraft won't let me stay on a server.

Discussion in 'General Minecraft Discussion' started by metalparott, Feb 9, 2013.

  1. Whenever I try to play on an Empire Minecraft server or any other online Minecraft server I get kicked off after anywhere from a few seconds to a few minutes. Minecraft then displays a message as follows:

    Connection Lost.png

    I have tried reinstalling java, minecraft (by deleting all the data in the AppData folder on my computer), and trying other fixes, like turing off firewalls to see if I am being blocked by them. My game seems to work just fine if I am playing on a LAN server though.

    I have searched everywhere I can think of to find solutions to this problem but none have worked (not to mention most forums and posts related to this issue seem to be at least 3 to 4 months old). I imagine it has something to do with either Java or Minecraft. The only other factor that could contribute to the issue is an internet filter program I use, and I am currently testing to see if it is the culprit to my problem. If anyone has any fixes, advice, or ideas on the subject, I would greatly appreciate it.

    Additional Info:

    My computer is a laptop that runs 64-bit Windows 7, connects to the routers and modems wirelessly (though it has the capability to have a wired connection), and has 4gb of RAM.
    IamSaj likes this.
  2. From my past experience, it is some issue with the internet connection. If I was a betting person- I bet you would not have any issues with a wired connection. (From experience)
    IamSaj and Sunny_Chicken like this.
  3. Try your 'wired connection' option and see if you have the same problem.
    Narrow down if the problem is your wireless network or your ISP.

    It's certainly strange that it is happening mid-game.
    Check you dont have any downloads going, as well as any other computers on the same connection.
    If they are using up all the bandwidth, it may cause your MC to fail to keep up and abort like so.
    IamSaj and Sunny_Chicken like this.
  4. As it turned out, the internet filter was the source of the problem. I downgraded it and the game connects just fine now. Thanks for the help though. Perhaps someone will find this thread useful in the future.
    IamSaj and Sunny_Chicken like this.