SMP3 rollback?

Discussion in 'Empire Help & Support' started by slash14459, Mar 27, 2013.

?

Was there a rollback for you?

Yes 10 vote(s) 71.4%
No 4 vote(s) 28.6%
  1. Earlier today I placed 2 stacks of emeralds into my shop chest and now it is gone. I have went through my rupee history and there was nothing about selling emeralds. Also I put 32 diamond in a chest and now it is gone as well. Pretty much everything I have done in the last 8 hours has been reversed. I even changed some of my shop prices and those are the price they were before now too. I asked another player on smp3 if the his stuff was missing and apparently he was missing a bunch of enchanted books. I don't know is this happened on sny of the other SMP's but I really hope there is a fix for this.

    EDIT: I also lost about 12k because someone sold me glowstone and it is no longer in the chest.
  2. same here....
    all the work iv done.. its simply gone. As well as nether quartz ores I brought from nether and put them in shop for sell... they are gone together with the chest. I have heard from other smp3 people, its is same for them... they have got rollback as well.
  3. I've let as many staff (incl. Aikar) as possible know. Hopefully if there is a problem it'll be fixed. :)
  4. I lost about 50 stacks of stonebrick yesterday and 20 diamond because i was building a new res and i was doing pretty good ,if this isnt rolled back i hate to say it but i might just leave empire.I lost few thousand rupees to.My jaw dropped when i saw my regular res.
  5. Bad stuff happens, and it's sad. But if you don't stay here, you won't see the epic stuff that's lined up for the future. :)
  6. Yes, bad stuff happens and I hope everyone to take it that calm as you do (even if it didnt affect you in this case)... including myself. Smp3 people are not too active on forums, so they dont actually put out here all the dissapointment they have got and progress/things/rupees lost. Because of that, probably the problem seems to be less than it is actually.
  7. hmm...

    I see a critical error on smp3 with the chunk saving thread... Def was the problem. I'm betting the file saving thread was dead after that.

    It should be ok now that the server rebooted, but was it essentially not saving anything anytime you left the area?

    I will work on resolving this. I believe it was a very unlucky timing of the auto-saves the system does every 15 mins.
    cddm95ace likes this.
  8. I lost 8 stacks of Red Wool. On the brighter side I now have 10 duplicated wooden doors in my inventory to add to the 10 wooden doors I didn't want in the first place. Wuh wuh wuuuh. :(
    cddm95ace and PandasEatRamen like this.
  9. Thank you for looking into it!

    The only time track I could really do, is checking my rupees history, as I set up quartz and someone bought some right after (which is gone today, so its seenable it had chunk save problem at that time already) and that was about 7.30pm for me (gmt+2). I was in nether on morning yesterday (aprox 11am) gathering quartz and made cobble+ladder way down, so If it is needed I might travel back to see if that progress is lost as well.

    There were not noticable problems with saving, even leaving residence and coming back, everything was still there. Same for logging off and coming back.
  10. thats very surprising really then...

    This is when the error occured in GMT:

    Code:
    smp3:2013-03-26 14:03:06 [SEVERE] Exception in thread "File IO Thread"
    smp3:2013-03-26 14:03:06 [SEVERE] java.util.ConcurrentModificationException
    smp3:2013-03-26 14:03:06 [SEVERE]       at java.util.HashMap$HashIterator.nextEntry(HashMap.java:894)
    smp3:2013-03-26 14:03:06 [SEVERE]       at java.util.HashMap$EntryIterator.next(HashMap.java:934)
    smp3:2013-03-26 14:03:06 [SEVERE]       at java.util.HashMap$EntryIterator.next(HashMap.java:932)
    smp3:2013-03-26 14:03:06 [SEVERE]       at net.minecraft.server.v1_5_R2.MetaApiAccessor.saveChunkMetaNbt(MetaApiAccessor.java:87)
    smp3:2013-03-26 14:03:06 [SEVERE]       at net.minecraft.server.v1_5_R2.ChunkRegionLoader.c(ChunkRegionLoader.java:172)
    smp3:2013-03-26 14:03:06 [SEVERE]       at net.minecraft.server.v1_5_R2.FileIOThread.b(SourceFile:29)
    smp3:2013-03-26 14:03:06 [SEVERE]       at net.minecraft.server.v1_5_R2.FileIOThread.run(SourceFile:22)
    smp3:2013-03-26 14:03:06 [SEVERE]       at java.lang.Thread.run(Thread.java:722)
    Basically the error says 2 things touched a data set at the same time, which isnt good...

    I never expected this to even be able to happen, but the automated save is the likely cause.
    Laurencem17 likes this.
  11. that all looks like gibberish to me :(
    PenguinDJ and AlexHallon like this.
  12. So, after losing half my tower I worked on... is it gonna come back? GF lost a whole stack of iron too, not funny. Fix it.
  13. About 7.30pm was time I returned from nether, so I was not doing anything at town before that time. Ill head over to nether to see if the progress there is lost or not. Getting curious.
    Huh... armor and weapons gone..

    Edit: progress in nether is lost partially, so yeah.. something has been done before error appeared, something after. Fingers crossed there is a chance to fix the things
  14. Thought as i work in the IT business, I keep telling people to make more backups.

    15 mins is a big window for things to happen, backup more :p

    I have lost my sugercane :(.
  15. I bet Aikar would LOVE to fix this, and to make sure everything is returned. Rudeness neither encourages him to, not helps make that possible.

    Note that the EMC staff do not refund items that are lost due to bugs to prevent scamming. If the saves can somehow be restored, then happy days, you get your stuff back. If not, life goes on.
  16. Hope none of my stuff is gone...
  17. Lol he unclaimed his res. Must have just been too overwhelming for him.
    PenguinDJ and PandasEatRamen like this.
  18. Something similar happened to me a few days ago on SMP5. I was at Wassatthen's shop and I paid for 2 pistons, but the pistons didnt appear in my inventory. I tried buying again from her shop sign but it said it was out of stock. I have container perms at her res so I checked inside the chest and there was a stack or more of pistons. It was weird but I just took out the pistons I needed and paid her for how much I took with /r pay instead.
    Don't know if thats still a problem but it happened again when I was buying sticky pistons from her also a day or 2 ago.


    Sorry I just realized this was just for SMP3 xD but I just thought I'd share that it happened to me in SMP5 also
  19. Have you had any block rollback on smp5? If so, i might be very upset later D:
  20. doesn't sound like its the same thing hey, but that's a really weird case.

    As for sMP3 there's nothing that can be done to bring it back, I will be working to avoid it happening again.

    We also could not even restore from backup.

    1) Our backups use to only be daily, our world folders are huge... we don't have much choice here, but we have increased it to 6 hours now with new hardware and better backup system
    2) It only affected some chunks. We can't restore selective chunks.
    3) Unfair to the others who weren't effected if we did a full restore, those people would then be rolled back essentially...

    I wish we could do more, bugs after updates always cause problems :(

    Only real option wed have to prevent issues like this is to simply not update for 1-2 months... but I'm sure no-one wants that.
    Laurencem17 and jkjkjk182 like this.