Problems with enchants

Discussion in 'Community Discussion' started by Magneto11, Jun 18, 2013.

  1. A few months ago, I used eff V, unbreaking III, and silk touch pick (all in one pick) and it was really super speedy like 4-5 blocks in like 1/2 a until a few months ago it started acting like a normal plain pick.......but last week it was speedy for like a day then it went back to a normal pick... I'm quite pissed off about this and I have no idea what's happening....can someone explain??
  2. I thought that something similar to this was happening with my shovels... Perhaps a bug with being able to do more than vanilla enchants using an anvil?
  3. It's just a glitch. If you notice it's acting up like that, just stop using it until later.
  4. Maybe you were picking up the effect from a Haste beacon somewhere? Haste II makes a big different to block destroying speed. :)
  5. Well I use it at randomzh's stonegen and I use it in the wild and it still doesn't work anyway
  6. There is a haste II beacon at randomzh's stonegen but it still doesn't work in the wild and there is no haste II there
  7. Magneto, instead of double posting, click the little edit button at the bottom of your post.

    A beacon effect will last for at most 8 seconds after you're out of the beacon's range.