Nothing happens when I right-click a shop sign

Discussion in 'Empire Help & Support' started by qwertyzzz18, Sep 9, 2012.

  1. I am trying to sell cactus at the shop on 2178, but when I right-click the sign to try and sell it, nothing happens. I can buy items, but selling them doesn't work. This happens at other shops too.
  2. Umm, I think I heard someone say this the other day - Try having nothing in your hand. I don't know if this helps - but it can't hurt to try
  3. Possibly lag: disconect, reconect, and try again.
  4. I did that. It continues.
  5. It happened to me, What I did, was step back a block. And sell it just normally. It turns out to be sold. Being right close to it would just do plain nothing.

    So far, It works for me :)
  6. Happens to me occasionally, probably lag. Whenever I move the item around in my inventory it lets me sell it again :)
  7. Does the shop sign have a sell option on it? or is it only buy. Surprised no one came up with this idea.
  8. Good point. But I get this all the time with buy and sell signs so I'm assuming it does.
  9. Solved! Problem was that I was holding an item. Switching to an empty slot fixed it.
  10. And you are now no longer a new member, now a normal plain ol', run of the mill member. :)