No tokens from enraged

Discussion in 'Empire Help & Support' started by fishmeal, Oct 26, 2014.

  1. I've been on difficulty 10 for a while (wow...not recommended), and I'm not receiving any tokens. I've killed a few enraged. I've collected all the rare drops (also wow, 3 dragon frags from 1 mob), but none of the token messages have been coming up, and I'm not getting tokens.
    They are only taking damage from my sword. I never get the "this monster is having trouble..." message. I always get drops. I've killed over a dozen enraged.

    I've had trouble in the past with this, and never solved it. One day it just started working again. I've been on difficulty 5 ever since. Yesterday I switched it to difficulty 1, and earlier today to 10.
    I suspect the switch has something to do with it, but I switched hours before meeting any of these mobs and I relogged.
  2. I also noticed no tokens from enraged today. I figured it was a glitch, but if you saw the same thing it must be something more.
  3. I can't remember a time when tokens have worked for everyone simultaneously. Someone is always having a problem, including often times me. Tokens need to be fixed for good.
  4. Just kidding, actually. Of course right after I post this it fixes itself. Well, after another relog.
    It seems like there's anywhere from hours to days of delay on tokens after switching from difficulty 1 to anything higher.
    That's assuming you're not supposed to get tokens on difficulty 1.

    It does seem so far like they stop dropping diamonds at difficulty 10 though which is sad. The dragon stone I got makes up for it though :D