Need Magic Launcher help

Discussion in 'General Minecraft Discussion' started by Mrlegitislegit, Jul 29, 2013.

  1. Simply put, it won't update. I updated the normal launcher: nothing. I reinstalled it: nothing. Any help would be nice. :)
  2. Which mods are you having issues with or want installed?
  3. Its not the mods, its the launcher its self, it won't update from 1.5.2.
  4. did you try downloading the new Magic Launcher?
  5. Yup.
  6. When ever I try, it says the 1.6.2 .jar is invalid, do you know how to help with that?
  7. Have you gone to Set-up and under Environment selected 1.6.2?
  8. Just saw it, thanks. :)
    cddm95ace likes this.
  9. Cough minecraft forge cough.

  10. Yeah, it took me a little while to figure it out. Glad you got it updated :)
  11. What does that have to do with anything in this thread?
  12. I am simply recommending that you use minecraft forge instead of magic launcher. I personally think it works better.
  13. Magic Launcher, especially if you're just using Optifine/Rei's, is a lot easier/simpler to use than Forge, and works just fine :)
  14. .... you can use Magic Launcher to load forge...

    You guys do know that Forge and ML are not the same thing right?
    Gadget_AD and PenguinDJ like this.