Need help running MC better.

Discussion in 'Empire Help & Support' started by jkjkjk182, Jun 13, 2012.

  1. I have a HP Elitebook 8760w with a Nvidia Quadro 4000m graphics card in it, and my minecraft stutters like a nervous kid who has had 87 bottles of pure caffeine. I have optifine and all of the options set to fast, i have 32gb of ram and i went into the java file and let it have access to 8gb, i have put the java process priority at high, i even have a 4x4 texture pack. Is there anything else i can do to speed it up? Also, i have a 2.3ghz intel quad core, so its not my processor. I really want to be able to play minecraft on this, because since i got this, my dad doesnt let me use the desktop for gaming anymore. Please help, any help is welcome!

    Edit: Also, Fallout 3 runs on all settings maxed out perfectly, no frame stuttering.

    marknaaijer likes this.
  2. Well looking at your specs I highly doupt that there is a hardware issue. Is there some mod you have installed or something else that is interfering with Java?
  3. So I've looked at all your spec's and that is a killer of a laptop, I really don't see anything that can cause it.
    xI_LIKE_A_PIGx likes this.
  4. I got an Acer Aspire 7741 with 4GB of RAM, and an Intel Pentium CPU P6200 @ 2.13GHz processor (It's a piece of junk), and I run MC almost perfectly fine. There must be something terribly wrong here.
  5. I would seriously reccomend a reinstall of windows, Do you know the product key of your computer?
    xI_LIKE_A_PIGx likes this.
  6. Well Jkjkjk, its not your hardware. You have allocated 8GB of memory to Java. I suggest you tone it down to 1 GB. If your computer stutters try getting OptiFine multi-core version. This allows your Minecraft to multi-thread making it even faster since you have a quad-core.

    SET all settings to normal, turn off fog, turn off clouds. Enable OpenGL at fast mode and hmm... This might help, posting some pictures below.
    jkjkjk182 likes this.
  7. I assume that machine is 64 bit, have you installed both the 32 and 64 bit versions of Java?

    8 GB is really overkill, 1 is sufficient.

    It varies from system to system, but I get better performance with Advanced OpenGL off. I think you only really get any benefit if you're struggling to get more than 60fps in the first place.
    thecontroller likes this.
  8. Also just a note if you are running background applications I suggest you close them when playing Minecraft since Java isn't a very efficient engine to run a game in.

    jkjkjk182 likes this.
  9. Nothing interferes with it, i have minimal installs so the laptop is faster.
    I reinstalled win7 pro a few days ago:/
    I have multi-core optifine, but i never touched OpenGL since i thought off was fastest! Thanks, i am going to try this for a while and i will see if this works consistently:)
  10. Alright, here's a list.

    First off, put back the normal texture pack, and I'd like to see what results you have by changing the draw distance. I wouldn't even worry about optifine yet, its not whats causing the issue. Personally, I would go back to vanilla minecraft and work up from there.

    It should work fine without any mods to it. I've got a server machine that uses onboard video, and it will run it. I'd make sure your drivers are all up to date (mainly video ones).

    Also check java for updates. Finally, make sure that you aren't smothering the video card (seriously). I've got an elitebook as well (at work) and it runs minecraft smoothly. If I lay in bed with it and smother the exhaust port for the video card, surprise surprise, things go wrong.
  11. OpenGL option has fixed it so far:)
    All my drivers were up to date, and also it sits on a three fan external laptop cooler, but thanks!:)
  12. Try without optifine! :)

    No seriously... try it without mods. Then add one at a time. The multicore version of optifine certainly doesnt always work well for me.
  13. He fixed it by turning on Advanced OpenGL
  14. You're very welcome :)

    OpenGL however is only supported in some graphic card drivers and should not be always be selected unless you are very sure. Research about your graphic card driver before turning on Advanced OpenGL.

    Turning on Advanced OpenGL without knowledge that your graphic card driver supports it, it will cause errors and incorrect textures.

    However in Jkjkjk's case it is fine.
    jkjkjk182 likes this.
  15. The OpenGL solution worked for a while, and nnow the stuttering has returned:(
    So now im going to try i clean force update of Minecraft and work from there:)
  16. Remember to use the settings I provided!