Mac Help - Not Turning On!

Discussion in 'Miscellaneous' started by THE_LEGEND4, Aug 4, 2013.

  1. I own an Early-2011 MacBook Pro, which I updated to the newest OSX - Mountain Lion earlier this year. Everything was fine until earlier today when I tried to boot it up - the regular grey apple logo showed up, but underneath was a progress bar of some kind. The bar would take about 5 minutes to fully load, then would disappear and a spiral 'Loading' indicator would pop up under the Apple logo. This screen has been the same for hours now and is not going to the login screen so we haven't been able to access that computer.

    I've tried doing everything, holding down option while booting, holding down Command + Option + R + P (I think that's right), but nothing has worked. If you have any idea about this, please share
    cutejuliew and sonicol1 like this.
  2. while booting hold command+s. that will boot it with a single user.
    If that doesnt work, try holding r.
    Thats all i got.
    THE_LEGEND4 likes this.
  3. Thanks for the info! I held Command + S, and it's on that massive code-thingy - am I meant to do anything now? :D
    cutejuliew and sonicol1 like this.
  4. I've had the loading bar once on my iMac, but it disappeared after it had fully loaded. My iMac is running Lion though not mountain lion as its to old for it. The only thing I can say to this is a bad driver or maybe out I date software. I'm not an expert but that's my guess.
    THE_LEGEND4 likes this.
  5. I think initially, the bar means the Mac is installing updates, - I'm not sure why it's stuck on the loading screen though...
    cutejuliew and sonicol1 like this.
  6. *sigh* Amateurs... Lol, just kidding! But for me to help, I'll need some more information. Did this happen right after you installed ML, after the first reboot, or just randomly (worked on ML, not working now)? Also, I'd love, love, love some screenshots of the loading bar screen. Anything else I can come up with will be posted here. :)
    cddm95ace and THE_LEGEND4 like this.
  7. Solution: Buy a PC

    (JK, although if the mac doesn't work after trying everything you might need to. Sorry that I can't help.
    I gif you an emerald.
    Best Minecraft Servers)
  8. Just leave it there until it runs out of battery. Once it runs out of battery, plug it in and try again. If that does not work, take it in to the nearest apple store and go back to the Genius Bar. Ask them to take a look at it.
    THE_LEGEND4 likes this.
  9. And if he misses the Mac interface/OS, then VirtualBox + iAtkos ML = Profit. :D
    THE_LEGEND4 likes this.
  10. It just happened randomly - I don't think it has anything to do with the installation or Mountain Lion. The computer has been bugging me about installing new updates for weeks now, maybe that has got to do with the problem? I've heard the bar usually indicates that he Mac is installing updates...

    As for screenshots, I'll try and get some. ;)
    cutejuliew, sonicol1 and 5chris100 like this.
  11. It won't install updates without you requesting it. So that won't be the problem. An early 2011 MacBook should be able to handle 10.8

    I'd ask shavingfoam, he'll probably know what to do.
    THE_LEGEND4 likes this.
  12. It sounds like it's installing updates. I would plug it in a leave it running until tomorrow morning. If you shut it down while it's installing updates, it can really mess things up.

    If it still hasn't gotten anywhere by tomorrow, I would call Apple Support (or just call them now). If you're OK with the risk of messing up your computer even more, you can try restarting it (you can force it to shut down by holding down the power button for 4-5 seconds).

    It shouldn't install updates unless you tell it to, but if it's been a long time since you've last run a software update, it might be trying to automatically install the critical security patches.
    mba2012 and THE_LEGEND4 like this.
  13. just power off. that shud do it!
    THE_LEGEND4 likes this.
  14. I've restarted it several times - I left it running overnight for about 13 hours, I'll just leave it some more. If nothing works, I'll just take it to Apple. :)
    cutejuliew and sonicol1 like this.
  15. Go back into Single User mode. Then, type exactly this: "/sbin/mount -uw /" without the quotes. This mounts the hard drive as the current location (similar to the "cd" command on Windows). After the drive is mounted, type "rm /var/db/.applesetupdone" and hit enter. This deletes the "Setup has been completed" file that was created after you went through setup when she first got the computer, thus allowing you to create a different administrator account and possibly getting you back into your computer. I cannot stress to you how important it is that you do not make any mistakes when typing this. Even though there is a chance that if you mess up the spelling that it spits back an error message, you might delete a different file from your hard drive. So, be careful! After you know that it is deleted, type "reboot" and hit enter. A pretty self-explanatory command, it restarts the computer. When it reboots, we should hope that the bar is gone. If it is, then go through the setup as if it were a new computer. WARNING: MAKE SURE TO SELECT "DO NOT TRANSFER MY DATA". When that's selected, all of your files will stay right where they are. Then, when it prompts you to create an administrator account, make sure to name it differently from another account. If you choose the same name as another user, it will overwrite the old one, deleting all of its files. Scary, right? :p Don't worry! When you're done, it should automatically log you into the new account. You are now free to go back to your old user and delete the new administrator account.

    If it didn't go into setup, but still hangs at the screen, then try rebooting again. Instead of holding Command-S for Single-User mode, hold down Command-V. This tells the computer to go into verbose mode, a kind of debugging, if you will. You'll be able to see exactly where it hangs, or if it even hangs at all. It could be trying and failing to load a kernel or invalid user.

    Try the two solutions and let me know the result of each of them. Hope this helps for you!
  16. Wow, thanks for all the time you've put into this! I've tried the first solution, but when I try the second command, nothing happens, I'll try it again in case I mistyped it. :)
    cutejuliew, sonicol1 and cddm95ace like this.
  17. Second... command? Do you mean "reboot"? If that's it, then you can just press (not hold!) the power button and wait for it to shut down. If you mean Command-V, make sure you're doing it at the Apple logo screen, not in Single-User mode. :)
    THE_LEGEND4 likes this.
  18. By second command, I meant the rm /var/db/.applesetupdone command. :)

    Anyway, I'm currently trying the second solution - it's been stuck at the text which says "continuing". How long does this process usually take? Thanks for your help, too! :)
    cutejuliew and sonicol1 like this.
  19. Did the setup screen show up at all? And no problem! :)
    THE_LEGEND4 likes this.
  20. A black screen with heaps of random text came up when I booted up the Mac with Command + V.
    cutejuliew and sonicol1 like this.