Logging in Error: "Connection Lost"

Discussion in 'Empire Help & Support' started by BionicBoa, Jun 16, 2015.

  1. I've been having a problem recently for about the past 12 hours in which I have trouble logging on. Whenever I try to join the server, I get a message that says:

    Connection Lost

    Internal Exception: io.netty.handler.codec.DecoderException:
    java.lang.IndexOutOfBoundsException: reader index(9) + length(1) Exceeds writerIndex(9): UnpooledHeapByteBuf(ridx: 9, widx: 9, cap: 9)

    *Hopefully I didn't make any typos, its kinda long.
    I am very confused by what this means and this appears every time I try to log in, and I DO log in when I click "join server" but, however, I only join for a fraction of a second, because I see my screen for a very short time before it disconnects and shows me this message. I hope their is a solution, and if anyone could find me one, I would be most grateful.

  2. Check your wifi / Ethernet connection your not getting a good connection might have to reset the modem
  3. Yeah i tried that, however, it seems to be something else, because I can join other servers just fine, and I can join this one, but whenever i do I get disconnected immediately. Thanks for the help :) , I'll try your solution again just to see if that might just work.
    Drmadfate likes this.
  4. i think i know what it is and should be fixed later tonight when I update us.
    Drmadfate likes this.
  5. Ok thank you so much :).
    Drmadfate likes this.
  6. It worked! Thank you so much! I can log on now, I can't thank you enough! :)
    Drmadfate likes this.