Is YouTube working for you?

Discussion in 'Community Discussion' started by DaJaKoe, Dec 12, 2012.

  1. I seem to have an issue with YouTube, numerous videos refuse to load and I just have an unchanging black screen, and last I checked my Adobe is up to date. Is this happening to anyone else?
  2. It happens to me every once and a while, did you try restarting your browser?
  3. I turned my computer off and back on.
  4. YouTube is working for me. Must be your internet.
    IamSaj likes this.
  5. Are you using google chrome?
  6. Safari.
    I'm able to see VEVO videos but not videos uploaded by normal YouTubers.
  7. Try downloading chrome...Its better :p And that may fix ur problem
  8. Best Minecraft Servers
    IamSaj, DogsRNice and talukegord like this.
  9. The :p face always comes up different than I think its gonna. I always think its gonna be kinda a "Meh" kinda thing like on facebook. And then it isn't and...It makes my post different....
  10. As taluk said, try using Chrome and if that doesn't work try it in incognito Chrome :)
  11. Alright, I now have a working YouTube on Safari again and a third search engine. Should I just complete the collection and get Internet Explorer?
  12. I hope you're joking
  13. Might aswell just install dog poo into your computer, it would work better
    Equinox_Boss, mba2012 and jkjkjk182 like this.
  14. Also when YouTube doesn't work, I can reset my router or turn my WiFi on/off and it usually works again. :)
    mba2012 likes this.
  15. You can install dog poo on your computer!!! WHAT!! Teach me!