I need help with Java

Discussion in 'Empire Help & Support' started by maask12345, Aug 19, 2014.

  1. So recently, I got a new laptop with 8gb of RAM. Because of this, I need to pay attention to things that are 64 bit and 32 bit and whatnot. I downloaded Java off of the website, but because of all this bit mumbo jumbo, I didn't feel like specifying what version I wanted, because I simply have no clue. I attempted to run Minecraft, which started up with no problem whatsoever, save for the fact that it was running with not even half a gig of RAM.

    Now, I tried to look up how to do that in the official launcher, but the long jumble of numbers and letters in the Java arguments scared me, so I went and downloaded Magic Launcher, because it's so much simpler. I set the game to allocate 1.5 gb, which worked fine, but when I attempted 2gb and 1600 mb, the game crashed. 2gb gave me a crash log upon hitting test, and 1600 mb ended up in the game crashing 5 seconds into loading a world, and creating a crash log in my .minecraft folder. Eventually I found out that I actually had 32 bit java installed, uninstalled that, and now I sit at the Java website, looking at a list of 64 bit downloads for windows, listed like so:

    Windows x86 Online: jre-7u67-windows-i586-iftw.exe
    Windows x86 Offline: jre-7u67-windows-i586.exe
    Windows x86: jre-7u67-windows-i586.tar.gz
    Windows x64: jre-7u67-windows-x64.exe
    Windows x64: jre-7u67-windows-x64.tar.gz

    Now, I have no clue at all which one is to be installed, but I'm sure that someone on EMC knows what they're talking about when it comes to this stuff. Afterwards, I'd like to know if I need to do anything special for mods, or if I need to do anything else special in order for Minecraft to run without errors.

  2. Go with this one I have it installed: Windows x64: jre-7u67-windows-x64.exe

    sambish20 likes this.
  3. If I'm correct, you want this one :) Windows x64: jre-7u67-windows-x64.exe
  4. Will do, I'll post the results after I test it.

    EDIT: Once I installed, I started up Magic Launcher, set the RAM to 1600 mb, and when I clicked test, a window popped up with this in it

    java.io.IOException: Server returned HTTP response code: 403 for URL: https://s3.amazonaws.com/Minecraft....twitch-platform/5.16/twitch-platform-5.16.jar
    sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
    java.lang.Thread.run(Unknown Source)

    It also has 2 more windows saying a library was not found, having to do with twitch. The game still started up, and with at least 1.5gb of memory, but for some reason, it said allocated memory 100%, and my fps felt a bit choppier.
    sambish20 likes this.
  5. Awesome :)
  6. Umm, run normal MC and use forge shouldn't have that problem
  7. I just ran with normal MC, it downloaded the twitch stuff, then I tried in Magic, and it didn't pop up any more.
    The difference between the two is that in normal, I figured out how to set it to 2gb of allocated memory, and it doesn't immediately say allocated memory 100% when I hit f3. In Magic, it does when I load the world.

    Looks like I'm gonna have to mess with vanilla to get all my mods working......based on past attempts, something tells me this won't be fun to do. Thank you for the help, I think that's all for the Java part of this.
  8. Honestly you shouldn't ever need 2 gigs of RAM unless you're doing some heavy modded gameplay. 1G is plenty enough for me to use. That's more of a micky-mouse way of fixing it, but if you don't need it there's no sense in going through struggles to get an ability you won't ever need or use.
  9. Well I've already gotten past those struggles, and I've played with 1G on my old computer, and sometimes I'd run out of memory or the game would just close without error. Since I have 8gb to use, I want 2G. I also intend on playing some FTB, and I know I'll need to do this for that, but this is how I want to play.

    Anyway, I've managed to install Optifine 1.7.2 with Forge, because I'd like to run Rei's Minimap with that. Unfortunately, I can't seem to figure out how to install the minimap with Forge now. I put the 1.7.2 zip file into the mods folder next to Optifine, but when I start up the game and load my world, the map isn't appearing, even if I press m, `, or whatever menu buttons for the mod. Moving the files from the zip into the Forge jar hasn't worked either.

    Is there any way I can get it to work, or am I going to need to play without a minimap?

    EDIT AGAIN: I've figured it out, I did a thing and now I have Optifine and Rei's without Forge. Thanks to those that helped