[Help] Replay mod & FFMPEG

Discussion in 'Miscellaneous' started by xHaro_Der, May 19, 2016.

  1. I'm trying to render a video using the Replay Mod and I'm constantly getting the error telling me that I need to install FFMPEG in order to render.

    I reinstalled FFMPEG twice so far with no dice. I also tried setting the path myself, using the Replay Mod batch file to set the path, I tried putting the path directly into the mod itself, and I tried running it from command line. Every single time, it just keeps telling me I need to install FFMPEG.

    Possible things that could be useful to know:
    - I have two drives. Minecraft is on E:\, system is on C:\. I installed FFMPEG to C:\. However, since the path is set into Windows itself, this should not be an issue and it should just redirect to C:\.
    - FFMPEG is installed to C:\FFMPEG\bin.
    - The only mods installed are shaders & replay mod.
    - I am using the MultiMC Minecraft launcher because it's objectively better than the regular Minecraft launcher. This should not be an issue at all because all it's doing is virtualizing the Minecraft instances and compiling them together into one arrangement. It's still normal Minecraft, just a different launcher.
    - I tried setting the environment variables as both 'path' (what it's supposed to be) and as 'ffmpeg'. Neither works.
    - I am using a texture pack. Probably irrelevant, but now you know.

    Anyone that knows anything about this issue and would be willing to help would be greatly appreciated..

    - Haro
  2. Update. It starts to render when I changed the command line settings to the ffmpeg.exe file itself. However, after rendering a couple frames, I get this:

    [09:46:03] [Client thread/INFO]:
    java.io.IOException: Cannot run program "ffmpeg" (in directory "E:\Desktop\[redacted]\MultiMC\instances\1.8 Shaders\minecraft\replay_videos"):
    CreateProcess error=2, The system cannot find the file specified