Custom skins not showing up?

Discussion in 'Empire Help & Support' started by sgx2000, Aug 8, 2012.

  1. So I just noticed this before... I have a custom skin and can see it on myself but everyone else looks like the vanilla skins and I look like the vanilla skin to everyone else.

    This is messing with my ability to roleplay and pretend that I'm either a Hobbit or Manu Ginobli... what gives?!?! lol
  2. I was just about to post the same thing. For me, I can't see my custom skin or anyone else's. I also can't see my custom skin on SSP.
  3. hmm that's weird. i can see my own custom skin when i view my inventory, so at least i have that!
  4. someone said crashed all skins went? on EMC mine doesnt work while on my server is does?
  5. I tried re-uploading my skin to, and I still look like steve.
  6. I can't see mine either :( I really hate steve's look.
    nfell2009 likes this.
  7. Restart your minecraft
  8. I've tried that. It doesn't work -_-
  9. you'll just have to close your eyes and imagine i'm Bilbo Baggins when you see me ok?! :)
    foodenator and nfell2009 like this.
  10. Lol
  11. The Minecraft skin servers are having problems. I was having the same problem but after a while it fixed itself.
    PenguinDJ and hayleycolgan like this.
  12. It is all part of the updating to the new 1.3 version. You all need to understand that with updates there are bugs, and you need to be patient. Try read the thread on the 1.3 update (on the home page) before you start posting threads, please.
  13. sorry, it was my Took side coming out when i made this
  14. Yea! I wanna show my Techno Piggeh off. :p
  15. It will help ALOT