Discussion in 'General Minecraft Discussion' started by Torrentwolf, Sep 17, 2011.

  1. For some reason, every two to five minutes my minecraft keeps crashing on the Empire server. I also keep getting this:

    # A fatal error has been detected by the Java Runtime Environment:
    # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x69ac1b13, pid=5260, tid=4752
    # JRE version: 6.0_27-b07
    # Java VM: Java HotSpot(TM) Client VM (20.2-b06 mixed mode windows-x86 )
    # Problematic frame:
    # C [nvoglv32.dll+0x5c1b13]
    # If you would like to submit a bug report, please visit:
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.

    --------------- T H R E A D ---------------

    Current thread (0x4d5c8000): JavaThread "Minecraft main thread" daemon [_thread_in_native, id=4752, stack(0x4f9c0000,0x4fa10000)]

    siginfo: ExceptionCode=0xc0000005, writing address 0x717de000

    EAX=0x717de000, EBX=0x717de000, ECX=0x501b1918, EDX=0x00000000
    ESP=0x4fa0f310, EBP=0x4fa0f31c, ESI=0x50180000, EDI=0x501b1ac8
    EIP=0x69ac1b13, EFLAGS=0x00010293

    Top of Stack: (sp=0x4fa0f310)
    0x4fa0f310: 00000000 00000000 00004003 4fa0f330
    0x4fa0f320: 69ac2dd4 50199ce4 50180000 50180000
    0x4fa0f330: 4fa0f338 6963908c 4fa0f348 695e596c
    0x4fa0f340: 510e1000 50199a80 4fa0f374 699358dd
    0x4fa0f350: 510e1000 00001878 00000000 50180000
    0x4fa0f360: 50180000 00000000 00000008 00000000
    0x4fa0f370: 00000109 4fa0f388 699022df 4d5c8000
    0x4fa0f380: 4fa0f3c4 00000000 4fa0f3d8 4ff28923

    Instructions: (pc=0x69ac1b13)
    0x69ac1af3: 8d 04 83 77 41 ff 24 95 ec 1b ac 69 8b 11 89 10
    0x69ac1b03: eb 34 8b 11 89 10 8b 51 04 89 50 04 eb 28 8b 11
    0x69ac1b13: 89 10 8b 51 04 89 50 04 8b 51 08 89 50 08 eb 16
    0x69ac1b23: 8b 11 89 10 8b 51 04 89 50 04 8b 51 08 89 50 08

    Register to memory mapping:

    EAX=0x717de000 is an unknown value
    EBX=0x717de000 is an unknown value
    ECX=0x501b1918 is an unknown value
    EDX=0x00000000 is an unknown value
    ESP=0x4fa0f310 is pointing into the stack for thread: 0x4d5c8000
    EBP=0x4fa0f31c is pointing into the stack for thread: 0x4d5c8000
    ESI=0x50180000 is an unknown value
    EDI=0x501b1ac8 is an unknown value

    Stack: [0x4f9c0000,0x4fa10000], sp=0x4fa0f310, free space=316k
    Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)

    [error occurred during error reporting (printing native stack), id 0xc0000005]

    Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
    J org.lwjgl.opengl.GL11.nglDrawArrays(IIIJ)V
    J nw.a()V
    J dk.a()V
    J n.a(Lls;Z)Z
    J px.a(FJ)V
    J px.b(F)V
    v ~StubRoutines::call_stub

    --------------- P R O C E S S ---------------

    Java Threads: ( => current thread )
    0x498fd400 JavaThread "Client write thread" daemon [_thread_blocked, id=3760, stack(0x5d000000,0x5d050000)]
    0x498fcc00 JavaThread "Client read thread" daemon [_thread_in_native, id=5776, stack(0x5cfb0000,0x5d000000)]
    0x4d62c400 JavaThread "Thread-14" daemon [_thread_blocked, id=6000, stack(0x51e50000,0x51ea0000)]
    0x4d62c000 JavaThread "Thread-13" daemon [_thread_blocked, id=4648, stack(0x51db0000,0x51e00000)]
    0x4d629800 JavaThread "Thread-12" daemon [_thread_in_native, id=1772, stack(0x51d60000,0x51db0000)]
    =>0x4d5c8000 JavaThread "Minecraft main thread" daemon [_thread_in_native, id=4752, stack(0x4f9c0000,0x4fa10000)]
    0x4d5c7800 JavaThread "Timer hack thread" daemon [_thread_blocked, id=3448, stack(0x4bc70000,0x4bcc0000)]
    0x49985c00 JavaThread "D3D Screen Updater" daemon [_thread_blocked, id=5880, stack(0x4e170000,0x4e1c0000)]
    0x49988400 JavaThread "TimerQueue" daemon [_thread_blocked, id=5052, stack(0x4bbf0000,0x4bc40000)]
    0x01411c00 JavaThread "DestroyJavaVM" [_thread_blocked, id=5764, stack(0x000c0000,0x00110000)]
    0x498cb800 JavaThread "AWT-EventQueue-0" [_thread_blocked, id=3988, stack(0x4ba30000,0x4ba80000)]
    0x4988c000 JavaThread "AWT-Windows" daemon [_thread_in_native, id=4116, stack(0x49ad0000,0x49b20000)]
    0x4988b800 JavaThread "AWT-Shutdown" [_thread_blocked, id=5060, stack(0x49a40000,0x49a90000)]
    0x49889000 JavaThread "Java2D Disposer" daemon [_thread_blocked, id=5020, stack(0x499f0000,0x49a40000)]
    0x014cb000 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=4344, stack(0x49750000,0x497a0000)]
    0x014c6c00 JavaThread "C1 CompilerThread0" daemon [_thread_blocked, id=5892, stack(0x01550000,0x015a0000)]
    0x014ba000 JavaThread "Attach Listener" daemon [_thread_blocked, id=5628, stack(0x01500000,0x01550000)]
    0x014b9000 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=2080, stack(0x01180000,0x011d0000)]
    0x0148f000 JavaThread "Finalizer" daemon [_thread_blocked, id=1452, stack(0x01130000,0x01180000)]
    0x0148a400 JavaThread "Reference Handler" daemon [_thread_blocked, id=5460, stack(0x010e0000,0x01130000)]

    Other Threads:
    0x01486400 VMThread [stack: 0x00cc0000,0x00d10000] [id=6104]
    0x014d4000 WatcherThread [stack: 0x497a0000,0x497f0000] [id=4408]

    VM state:not at safepoint (normal execution)

    VM Mutex/Monitor currently owned by a thread: None

    def new generation total 157376K, used 65007K [0x035c0000, 0x0e080000, 0x18b10000)
    eden space 139904K, 38% used [0x035c0000, 0x06ab6110, 0x0be60000)
    from space 17472K, 61% used [0x0cf70000, 0x0d9f5bb8, 0x0e080000)
    to space 17472K, 0% used [0x0be60000, 0x0be60000, 0x0cf70000)
    tenured generation total 349568K, used 62497K [0x18b10000, 0x2e070000, 0x435c0000)
    the space 349568K, 17% used [0x18b10000, 0x1c818690, 0x1c818800, 0x2e070000)
    compacting perm gen total 16896K, used 16780K [0x435c0000, 0x44640000, 0x475c0000)
    the space 16896K, 99% used [0x435c0000, 0x44623138, 0x44623200, 0x44640000)
    No shared spaces configured.

    Code Cache [0x015c0000, 0x01a48000, 0x035c0000)
    total_blobs=2366 nmethods=2040 adapters=260 free_code_cache=28820992 largest_free_block=128

    Dynamic libraries:
    0x00400000 - 0x00424000 C:\Program Files\Java\jre6\bin\javaw.exe
    0x77120000 - 0x7723e000 C:\Windows\system32\ntdll.dll
    0x76e30000 - 0x76f08000 C:\Windows\system32\kernel32.dll
    0x75b50000 - 0x75c0f000 C:\Windows\system32\ADVAPI32.dll
    0x75eb0000 - 0x75f73000 C:\Windows\system32\RPCRT4.dll
    0x75ab0000 - 0x75b4e000 C:\Windows\system32\USER32.dll
    0x75a60000 - 0x75aab000 C:\Windows\system32\GDI32.dll
    0x77270000 - 0x7728e000 C:\Windows\system32\IMM32.DLL
    0x77290000 - 0x77357000 C:\Windows\system32\MSCTF.dll
    0x76f20000 - 0x76fca000 C:\Windows\system32\msvcrt.dll
    0x76f10000 - 0x76f19000 C:\Windows\system32\LPK.DLL
    0x75c10000 - 0x75c8d000 C:\Windows\system32\USP10.dll
    0x7c340000 - 0x7c396000 C:\Program Files\Java\jre6\bin\msvcr71.dll
    0x6d7f0000 - 0x6da9f000 C:\Program Files\Java\jre6\bin\client\jvm.dll
    0x741d0000 - 0x74203000 C:\Windows\system32\WINMM.dll
    0x76190000 - 0x762d4000 C:\Windows\system32\ole32.dll
    0x759d0000 - 0x75a5c000 C:\Windows\system32\OLEAUT32.dll
    0x740d0000 - 0x74108000 C:\Windows\system32\OLEACC.dll
    0x75800000 - 0x7582c000 C:\Windows\system32\apphelp.dll
    0x6d7a0000 - 0x6d7ac000 C:\Program Files\Java\jre6\bin\verify.dll
    0x6d320000 - 0x6d33f000 C:\Program Files\Java\jre6\bin\java.dll

    Forum won't let me post the rest. Can anyone explain whats going on?
    xI_LIKE_A_PIGx likes this.
  2. I don't really know what's causing the problem, but manually uninstalling and reinstalling Java should fix it.
    jrm531 and xI_LIKE_A_PIGx like this.
  3. The first thing I would do (as AusQB said) is re-install Java:
    Also are you using any mods / client side plugins / Spoutcraft / etc ?
    xI_LIKE_A_PIGx likes this.
  4. I have never downloaded a mod before in my game playing life. Though I have been considering it. Couple of mods I'd like to play around with, like the nuke mod.
    xI_LIKE_A_PIGx likes this.
  5. Just tried that and it didn't work.
    xI_LIKE_A_PIGx likes this.
  6. Anyone else have an idea whats going on?
    xI_LIKE_A_PIGx likes this.
  7. Did you try deleting your .minecraft folder completely and installing it fresh? I searched around and people with similar problems seemed to solve it like that.
    xI_LIKE_A_PIGx likes this.
  8. How do I do that?
  9. FIRST try this:

    In the Minecraft launcher (before you sign in) click "Options"
    Click "Force Update"
    Sign in and the game should re download everything

    SECOND try (if it doesnt work):

    In the Minecraft launcher (before you sign in) click "Options"
    Click on the "Game location on disk"
    GO up one directory
    Now you should see the folder .minecraft
    change the name of it to .minecraft_backup (so you wont lose saves)
    Try to start Minecraft again and it should download everything fresh
    xI_LIKE_A_PIGx likes this.
  10. The first didn't work and the file name won't change.
    xI_LIKE_A_PIGx likes this.
  11. Any other idea's?
    xI_LIKE_A_PIGx likes this.
  12. I think I've fixed it. I'll let you know as I play.
    xI_LIKE_A_PIGx likes this.
  13. What did you do to fix it?
    xI_LIKE_A_PIGx likes this.
  14. Nope, it's still crashing.

    Edit for last post: I thought I fixed the crashing from the first post.
    xI_LIKE_A_PIGx likes this.
  15. you need to reinstall so go and delete .minecraft and redownload
    xI_LIKE_A_PIGx likes this.
  16. It didn't work either. And that's just the Empire server. I'd hate to see what happens offline.
    xI_LIKE_A_PIGx likes this.
  17. Any other ideas?
    xI_LIKE_A_PIGx likes this.
  18. Sounds very weird that those didn't fix it. Now just to update for those that might have more ideas:

    Does this happen in single player?
    You say it happens when you join our server. How about when you join other servers?
    xI_LIKE_A_PIGx likes this.
  19. I haven't tried single player, nor have I tried other servers. This all started when I reset my computer because of a virus.
    xI_LIKE_A_PIGx likes this.
  20. What version of windows are you running?
    xI_LIKE_A_PIGx likes this.