Cannot connect to server error

Discussion in 'Empire Help & Support' started by Curundu, Oct 25, 2013.

  1. Hi,

    I would appreciate any insight as to why this is happening. I connected fine just last night.

  2. Is this for all EMC servers, just one EMC server or all multiplayer servers?

    It could be related to 1.7, I assume you didn't update right?
  3. All EMC servers.
  4. To be honest EMC servers are the only ones listed in my server list.
  5. Check your revision. Is it 1.7 or 1.64?
  6. That's the problem, isn't it?
    Pab10S likes this.
  7. Yup, right now, you can only connect to EMC with 1.6.2, or 1.6.4. :)
    Pab10S likes this.
  8. Aikar has to update the server every little while to keep up with updates. It will take about a week.
  9. Does the message not say "Outdated Server - visit" ?
  10. Press edit profile when on the launcher and choose 1.6.4 rather than 1.7.2 or latest update and you can use that until 1.7.2 is adapted for EMC :)
  11. FDNY21 you are a genius sir.
    FDNY21 likes this.
  12. You are a genius as well, sir. :D
  13. Thanks you sir :cool: