Broken Redstone Repeater?

Discussion in 'Empire Help & Support' started by melodytune, Jan 19, 2012.

  1. I read that on some minecraft servers repeaters have been known to stop working. I built a cobble generator on my land that worked well for quite a while. Now it has stopped working. I am mostly positive that the problem is in the repeater. If I flip the switch the charge will go through and the cobble will come up. But it will only send the one charge, it will not repeat it. I have tried the following; breaking the repeater and putting it back down, messing with the repeater speed, making a new repeater and placing it.

    Is anyone else having an issue like this? Is there any way for me to repair it? Thanks ^_^

  2. When you walk away from your residence and nobody is near, the chunk will unload. This pauses (among other things) the function of redstone and the "frozen" redstone must be reset by being updated. :)
  3. Not sure if this has anything to do with it or not, but don't you need more than one repeater to actually make the charge repeat?

    I don't know the full situation, and I am by no means a redstone expert... just posing this question to help troubleshoot.
  4. ah ha.. well that actually makes sense. So how do I update it if breaking it and laying it down again isnt working? Any idea?
  5. What do you mean the repeater won't repeat? Repeaters repeat in the sense that they extend the distance the signal travels (they also act as diodes and delays).

    If the problem is you're not getting a pulse, as in constant timed signals, that's done with a clock which is a circuit containing repeaters and torches. I think a common problem is torches burning out, so perhaps try breaking and putting torches back down.
  6. Sorry I did not specify. It is in a clock but every aspect of the clock seems to be doing the job except the repeater. :)
  7. Sometimes the Redstone that is powering the repeater will get stuck (Or other places where the input is off but the output is on)

    Remember to do NOR gates on opposite, input true output true and such. As a rule of thumb (For me) I don't use redstone torches in excess while building on SMP as they tend to.... be problematic. :)
  8. Thanks all! Such quick responses. Ya'll are awsome :)
    Crazy1080 likes this.
  9. Maybe try destroying the entire clock and putting it back down?
  10. this site shows a clock with one repeater, but more repeaters can be used to slow down the pulse.

    I'm no expert either, I've just made a lot of mistakes. I think if you've tried all the possibilities on replacing a component and it still doesn't work, it's probably a symptom of a problem / glitch elsewhere.
  11. Yeah who knows. I will very likely keep tinkering with it just because I like playing with the electrical system. But knowing that in all likelihood it will break again I'm not going to devote a whole lot of effort. I was planning on working on a note block project but now starting to wonder if I should drop the idea - at least for a while.
  12. Keep tinkering :) The worst that could happen is you learn a bunch of ways that don't work, but nothing beats the ah-ha when you figure out the problem, even when it's a minecraft glitch :)